1142 Maximal Clique (25 point(s))

1142 Maximal Clique (25 point(s))

clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

题意分析:

在一个无向图中,如果在给定的顶点集中任意两个不同的点之间都有一条边,那么我们称这样的点集为Clique。如果一个Clique点集不可以再加入任何一个新的结点构成新的Clique(即是最大的),我们称这样的Clique为Maximal Clique。给定无向图和子集,进行判断。

使用邻接矩阵存储无向图,将给出的子集存储在set<int> s中,按照定义暴力求解。

1. 先判断是不是Clique。遍历s中任意两个元素,如果存在graph[i][j]==false则不是;

2. 再判断是不是Maximal Clique。遍历每一个不在s的元素i,如果存在对于s中所有的j有graph[i][j]==true,则不是;

3. 否则输出“Yes”。

完成本题后的反思:STL中set/vector等查找元素是否存在、个数等库函数

#include<iostream>
#include<cstring>
#include<vector>
#include<set>
using namespace std;
const int N = 207;
int nv,ne;
bool graph[N][N]={false};
set<int> s;
bool isClique(){
	set<int>::iterator i;
	for(i=s.begin();i!=s.end();i++){
		set<int>::iterator j=i;
		for( j++;j!=s.end();j++){
			if(!graph[(*i)][(*j)]) return false;
		}
	}
	return true;
}
bool isMax(){
	for(int i=1;i<=nv;i++){
		if(s.find(i)==s.end()){//如果不在这个集合
			bool flag = false; 
			set<int>::iterator it;
			for(it=s.begin();it!=s.end();it++){
				if(!graph[i][*it]){
					flag =true;break;
				}
			} 
			if(!flag) return false;
		}
	}
	return true;
}
int main(void){
	int a,b,M;cin>>nv>>ne;
	while(ne--){
		cin>>a>>b;
		graph[a][b]=graph[b][a]=true;
	}
	int K,x;cin>>M;
	while(M--){
		s.clear();
		cin>>K;
		while(K--){
			cin>>a;
			s.insert(a); 
		}
		if(!isClique()) cout<<"Not a Clique"<<endl;
		else if(!isMax()) cout<<"Not Maximal"<<endl;
		else cout<<"Yes"<<endl;
	}
	return 0;
}

此题的主要操作是要对特定的边是否存在进行判断,因此使用邻接矩阵更加简单。

大神用向量数组存储的代码:

https://blog.youkuaiyun.com/richenyunqi/article/details/79837901

标题Python网络课程在线学习平台研究AI更换标题第1章引言介绍Python网络课程在线学习平台的研究背景、意义、国内外现状和研究方法。1.1研究背景与意义阐述Python在线学习平台的重要性和研究意义。1.2国内外研究现状概述国内外Python在线学习平台的发展现状。1.3研究方法与论文结构介绍本文的研究方法和整体论文结构。第2章相关理论总结在线学习平台及Python教育的相关理论。2.1在线学习平台概述介绍在线学习平台的基本概念、特点和发展趋势。2.2Python教育理论阐述Python语言教学的理论和方法。2.3技术支持理论讨论构建在线学习平台所需的技术支持理论。第3章Python网络课程在线学习平台设计详细介绍Python网络课程在线学习平台的设计方案。3.1平台功能设计阐述平台的核心功能,如课程管理、用户管理、学习跟踪等。3.2平台架构设计给出平台的整体架构,包括前后端设计、数据库设计等。3.3平台界面设计介绍平台的用户界面设计,强调用户体验和易用性。第4章平台实现与测试详细阐述Python网络课程在线学习平台的实现过程和测试方法。4.1平台实现介绍平台的开发环境、技术栈和实现细节。4.2平台测试对平台进行功能测试、性能测试和安全测试,确保平台稳定可靠。第5章平台应用与效果分析分析Python网络课程在线学习平台在实际应用中的效果。5.1平台应用案例介绍平台在实际教学或培训中的应用案例。5.2效果评估与分析通过数据分析和用户反馈,评估平台的应用效果。第6章结论与展望总结Python网络课程在线学习平台的研究成果,并展望未来发展方向。6.1研究结论概括本文关于Python在线学习平台的研究结论。6.2研究展望提出未来Python在线学习平台的研究方向和发展建议。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值