HDU3306 矩阵快速幂


/*****************
Sn-1                         1   X^2  Y^2  2XY             Sn
An-1^2              *       0   X^2  Y^2  2XY    =       An^2
An-2^2                      0    1     0      0               An-1^2
An-1An-2                  0    X     0      Y               AnAn-1

用自己写的矩阵的类模板居然会超时,改成简单的面向过程就过了

*******************/


Another kind of Fibonacci

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1355    Accepted Submission(s): 534


Problem Description
As we all known , the Fibonacci series : F(0) = 1, F(1) = 1, F(N) = F(N - 1) + F(N - 2) (N >= 2).Now we define another kind of Fibonacci : A(0) = 1 , A(1) = 1 , A(N) = X * A(N - 1) + Y * A(N - 2) (N >= 2).And we want to Calculate S(N) , S(N) = A(0) 2 +A(1) 2+……+A(n) 2.

 

Input
There are several test cases.
Each test case will contain three integers , N, X , Y .
N : 2<= N <= 2 31 – 1
X : 2<= X <= 2 31– 1
Y : 2<= Y <= 2 31 – 1
 

Output
For each test case , output the answer of S(n).If the answer is too big , divide it by 10007 and give me the reminder.
 

Sample Input
  
  
2 1 1 3 2 3
 

Sample Output
  
  
6 196
 
# include<iostream>
# include<stdio.h>
# include<string.h>
using namespace std;

const int mod=10007;

struct Matrix{
  int element[4][4];
};

Matrix Multiply(Matrix a, Matrix b)
{
    Matrix ans;
    for(int i=0; i<4; i++)
      for(int j=0; j<4; j++)
      {
          ans.element[i][j]=0;
          for(int k=0; k<4; k++)
          {
            ans.element[i][j]+=(a.element[i][k]*b.element[k][j])%mod;
            ans.element[i][j]%=mod;
          }
      }
   return ans;
}

Matrix quickpow(Matrix a, int n)
{
    Matrix result;
    for(int i=0; i<4; i++)
        for(int j=0; j<4; j++)
          if(i==j) result.element[i][j]=1;
          else  result.element[i][j]=0;
    while(n)
    {
        if(n&1)
            result = Multiply(result, a);
        n=n>>1;
        a=Multiply(a, a);
    }
    return result;
}

int main()
{
    int n, x, y;
    while(~scanf("%d%d%d", &n, &x, &y))
    {
        x=x%mod;
        y=y%mod;
        Matrix a;
        for(int i=0; i<4; i++)
            for(int j=0; j<4; j++)
              a.element[i][j]=0;
        a.element[0][0]=a.element[2][1]=1;
        a.element[0][1]=a.element[1][1]=(x*x)%mod;
        a.element[0][2]=a.element[1][2]=(y*y)%mod;
        a.element[0][3]=a.element[1][3]=(2*x*y)%mod;
        a.element[3][1]=x;
        a.element[3][3]=y;
        a=quickpow(a, n-1);
        int ans=(a.element[0][0]*2+a.element[0][1]+a.element[0][2]+a.element[0][3])%mod;
        printf("%d\n", ans);

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值