1135 Is It A Red-Black Tree-PAT甲级

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpgrbf2.jpgrbf3.jpg
Figure 1Figure 2Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

 题意分析
红黑树是一种平衡二叉查找树,它满足以下要求:
(1)每个节点都是红色或黑色。
(2)根是黑色的。
(3)每个叶子(NULL)都是黑色的。
(4)如果一个节点是红色的,那么它的两个孩子都是黑色的。
(5)对于每个节点,从节点到后代叶子结点的所有简单路径包含相同数量的黑色节点。
给出树的先根序列,判断该树是否是红黑树。
根据给出的树的先根序列,可以利用二叉搜索树的插入算法直接构造出二叉搜索树

性质1不必检验

性质2检查根结点的数值即可

性质3不必检验

性质4用dfs搜索检验红色结点的孩子结点是否为黑色即可

性质5用dfs检验任意一个结点的左右子树的黑色结点是否相同即可,涉及到计算黑色结点的个数,利用递归算法求解即可

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
int flag=1;//用来检测性质4是否成立 
int ff=1;//用来检验性质5是否成立 
struct node{
	int data;//数据域
	node *lchild=NULL;//左子树
	node *rchild=NULL;//右子树 
};
void insert(node *&root,int data){
	if(root==NULL){
		root=new node;
		root->data=data;
		return;
	}
	if(abs(data)<abs(root->data)){
		insert(root->lchild,data);
	}else{
		insert(root->rchild,data);
	}
}
void dfs(node *root){
	if(flag==0) return; 
	if(root==NULL) return;
	if(root->data<0){
		if(root->lchild!=NULL){
			if(root->lchild->data<0)
				flag=0;
		}
		if(root->rchild!=NULL){
			if(root->rchild->data<0)
				flag=0;
		}
	}
	dfs(root->lchild);
	dfs(root->rchild);
}
//判断性质5
int get(node *root){//判断某个结点开始的黑色结点的个数 
	if(root == NULL)
		return 0;
	int l = get(root->lchild);
	int r = get(root->rchild);
	return root->data > 0 ? l + 1: l;	
}
void dfs2(node *root){
	if(ff == 0) return;
	if(root == NULL) return;
	if(get(root->lchild) != get(root->rchild)){
		ff = 0;
		return;
	}
	dfs2(root->lchild);
	dfs2(root->rchild);	
}
int k,n;
int main(){
	scanf("%d",&k);
	for(int i=1;i<=k;i++){
		scanf("%d",&n);
		node *root=NULL;
		int x;
		flag=1,ff=1;
		for(int j=1;j<=n;j++){
			scanf("%d",&x);
			insert(root,x);
		}
		//判断性质二
		if(root->data<0){
			printf("No\n");
			continue;
		} 
		//判断性质4; 
		dfs(root);
		if(!flag){
			printf("No\n");
			continue;
		}
		dfs2(root);
		if(!ff){
			printf("No\n");
			continue;
		}
		printf("Yes\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值