1076 Forwards on Weibo(BFS)

1076 Forwards on Weibo (30 分)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

思路:先记录每个博主有哪些粉丝,然后广度优先,遍历每个粉丝,直到已被访问过或者超过了最大层数。

注意:每次查询开始前要对vis(是否访问过)这个数组初始化。

数组初始化:memset,fill函数都可以,memset主要用于0 、-1、inf

(18条消息) 【C++】fill函数,fill与memset函数的区别_柳婼 の blog-优快云博客_fill和memset

#include <iostream>
#include <cstring>
#include "queue"
#include "vector"
using namespace std;
const int maxx=1100;
int N,L;
struct node{
    int id;
    int  level;
};
vector<node> follow[maxx];
bool vis[maxx]={false};
int BFS(int s){
    int numforwards=0;
    queue<node> m;
    node start={s,0};
    m.push(start);
    vis[start.id] = true;
    while (!m.empty()){
        node top = m.front();
        m.pop();
        for (int i = 0; i < follow[top.id].size();++i) {
            node next = follow[top.id][i];
            next.level = top.level+1;
            if (vis[next.id]== false && next.level<=L){
                m.push(next);
                vis[next.id] = true;
                numforwards++;
            }
        }
    }
    return numforwards;
}
int main() {
    cin>>N>>L;
    int temp,follower;
    for (int i = 1; i <= N; ++i) {
        cin>>temp;
        for (int j = 0; j < temp; ++j) {
            node user;
            user.id = i;
            cin>>follower;
            follow[follower].push_back(user);
        }
    }
    int K,query;
    cin>>K;
    for (int i = 0; i < K; ++i) {
        memset(vis, false,sizeof(vis));
        cin>>query;
        int ans = BFS(query);
        cout<<ans<<endl;
    }
}

### CSS `animation-fill-mode` 属性中的 `forwards` 值 当定义动画时,`animation-fill-mode` 属性指定了目标元素在动画执行之前或之后应用哪些样式。对于 `forwards` 值而言,在动画完成后,被动画影响的属性会保留其最后的关键帧值(而不是恢复到初始状态)。这意味着即使动画结束,最终的状态仍然会被保持。 #### 使用示例 下面是一个简单的例子来展示如何使用带有 `forwards` 的 `animation-fill-mode`: ```css /* 定义关键帧 */ @keyframes fadeIn { from { opacity: 0; } to { opacity: 1; } } /* 应用动画并设置 fill mode */ .fade-in-element { animation-name: fadeIn; animation-duration: 2s; animation-fill-mode: forwards; } ``` 在这个案例里,`.fade-in-element` 类下的 HTML 元素将会逐渐变得不透明,并且一旦动画完成,这些元素将继续维持完全可见的状态,而不会返回原来的不可见形式[^1]。 #### 实际应用场景 考虑一个按钮点击后显示提示框的情况。可以利用 `forwards` 来确保提示框在关闭前一直保持最新的视觉效果直到手动隐藏它为止。 ```html <button id="show-toast">Show Toast</button> <div class="toast hidden"></div> <style> .hidden { display:none;} .toast { /* 初始状态下隐藏 toast */ visibility:hidden; @keyframes slideInDown { from { transform: translateY(-100%); } to { transform: translateY(0); } } animation-name:slideInDown ; animation-duration:.5s; animation-fill-mode:forwards; /* 动画结束后不再隐藏 */ visibility:visible !important; } </style> <script> document.getElementById('show-toast').addEventListener('click', function() { document.querySelector('.toast').classList.remove('hidden'); }); </script> ``` 这段代码展示了通过移除 `.hidden` 类使提示框显现出来的同时启动下滑进入屏幕中心位置的效果;由于设置了 `forwards`, 提示框将在动画结束后停留在屏幕上直至进一步操作将其再次隐藏.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值