1135 Is It A Red-Black Tree (30 分)
There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:
- (1) Every node is either red or black.
- (2) The root is black.
- (3) Every leaf (NULL) is black.
- (4) If a node is red, then both its children are black.
- (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.
For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.
![]() | ![]() | ![]() |
---|---|---|
Figure 1 | Figure 2 | Figure 3 |
For each given binary search tree, you are supposed to tell if it is a legal red-black tree.
Input Specification:
Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.
Output Specification:
For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.
Sample Input:
3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17
Sample Output:
Yes
No
No
#include<iostream>
#include<cmath>
#include<cstring>
using namespace std;
typedef struct node{
int data;
struct node *lchild,*rchild;
}tree;
void create(tree *&root,int key){
if(root == NULL){
root = (tree *)malloc(sizeof(tree));
root->data = key;
root->lchild = root->rchild = NULL;
}else{
if(abs(root->data)>abs(key)){
create(root->lchild,key);
}else{
create(root->rchild,key);
}
}
}
int judge1(tree *root){ //判断红色节点的孩子,都是黑色
if(root == NULL) return 1;
if(root->data < 0){
if(root->lchild != NULL && root->lchild->data < 0) return 0;
if(root->rchild != NULL && root->rchild->data < 0) return 0;
}
return judge1(root->lchild)&&judge1(root->rchild);
}
int high(tree *root){
if(root== NULL) return 0;
int l = high(root->lchild);
int r = high(root->rchild);
return root->data > 0 ? max(l,r)+1 : max(l,r); //当前根节点的高度
}
int judge2(tree *root){
if(root == NULL) return 1;
int l = high(root->lchild);
int r = high(root->rchild);
if(l != r) return 0;
return judge2(root->lchild)&&judge2(root->rchild); //判断每个根节点是否符合
}
int main(){
int k,n;
cin >> k;
while(k--){
cin >> n;
int a[35];
tree *root;
root = NULL;
for(int i = 0;i < n;i++){
cin >> a[i];
create(root,a[i]);
}
if(a[0] < 0 || judge1(root) == 0 || judge2(root) == 0){
cout << "No" << endl;
}else{
cout << "Yes" << endl;
}
}
return 0;
}