Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <231). It is guaranteed that the number of digits of Z is an even number.
Output Specification:
For each case, print a single line Yes
if it is such a number, or No
if not.
Sample Input:
3
167334
2333
12345678
Sample Output:
Yes
No
No
#include<iostream>
#include<string>
using namespace std;
int main(){
int n;
cin >> n;
while(n--){
string s;
string c1,c2;
cin >> s;
int top = 0;
c1 = s.substr(0,s.length()/2);
c2 = s.substr(s.length()/2);
int a,b,sum;
a = stoi(c1);
b = stoi(c2);
sum = stoi(s);
if(a*b != 0 && sum%(a*b)==0){
cout << "Yes" << endl;
}else{
cout << "No" << endl;
}
}
return 0;
}
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
using namespace std;
int main(){
int n;
cin >> n;
for(int k = 0;k < n;k++){
char s[100001]={};
char c1[100001]={},c2[100001]={};
scanf("%s",s);
int top = 0;
//cout << strlen(s) << endl;
//cout << c1 << " " << c2 << endl;
for(int i = 0;i < strlen(s);i++){
if(i < strlen(s)/2){
c1[i] = s[i];
}else{
c2[top++] = s[i];
}
}
int a,b,sum;
a = stoi(c1);
b = stoi(c2);
//cout << a << " " << b << endl;
sum = stoi(s);
//cout << sum << endl;
if(a*b != 0 && sum%(a*b)==0){
cout << "Yes" << endl;
}else{
cout << "No" << endl;
}
}
return 0;
}