1132 Cut Integer (20 分)

探讨了将一个整数切割成两个较小整数,并判断原整数是否能被这两个小整数的乘积整除的问题。输入包含多个测试用例,每个用例给出一个待测试的整数。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <2​31​​). It is guaranteed that the number of digits of Z is an even number.

Output Specification:

For each case, print a single line Yes if it is such a number, or No if not.

Sample Input:

3
167334
2333
12345678

Sample Output:

Yes
No
No
#include<iostream>
#include<string>
using namespace std;
int main(){
	int n;
	cin >> n;
	while(n--){
		string s;
		string c1,c2;
		cin >> s;
		int top = 0;
		c1 = s.substr(0,s.length()/2);
		c2 = s.substr(s.length()/2);
		int a,b,sum;
		a = stoi(c1);
		b = stoi(c2);
		sum = stoi(s);
		if(a*b != 0 && sum%(a*b)==0){
			cout << "Yes" << endl; 
		}else{
			cout << "No" << endl;
		}
	}
	return 0;
}
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
using namespace std;
int main(){
	int n;
	cin >> n;
	for(int k = 0;k < n;k++){
		char s[100001]={};
		char c1[100001]={},c2[100001]={};
		scanf("%s",s);
		int top = 0;
		//cout << strlen(s) << endl;
		//cout << c1 << " " << c2 << endl;
		for(int i = 0;i < strlen(s);i++){
			if(i < strlen(s)/2){
				c1[i] = s[i];
			}else{
				c2[top++] = s[i];
			}
		}
		int a,b,sum;
		a = stoi(c1);
		b = stoi(c2);
		//cout << a << " " << b << endl;
		sum = stoi(s);
		//cout << sum << endl;
		if(a*b != 0 && sum%(a*b)==0){
			cout << "Yes" << endl; 
		}else{
			cout << "No" << endl;
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值