1132 Cut Integer(20 分)
Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <231). It is guaranteed that the number of digits of Z is an even number.
Output Specification:
For each case, print a single line Yes
if it is such a number, or No
if not.
Sample Input:
3
167334
2333
12345678
Sample Output:
Yes
No
No
注:考虑A*B=0的情况 【这个点一直过不去(;´д`)ゞ
代码:
#include <bits/stdc++.h>
using namespace std;
typedef unsigned long long LL;
LL power(int x)
{
LL ans=1;
for(int i=0;i<x;i++)ans*=10;
return ans;
}
int main()
{
//cout<<power(3);
int t;scanf("%d",&t);
while(t--)
{
LL a;
cin>>a;
LL A=a;
int cnt=0;
while(a)
{
a/=10;
cnt++;
}
int num=cnt/2;
LL l=cnt-num,r=num;
l=A/power(r);r=A-l*power(r);
if(l!=0&&r!=0&&A%(l*r)==0){
printf("Yes\n");
}
else printf("No\n");
}
}