Fibonacci Again
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 51621 Accepted Submission(s): 24423
Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
Output
Print the word "yes" if 3 divide evenly into F(n).
Print the word "no" if not.
Print the word "no" if not.
Sample Input
0 1 2 3 4 5
Sample Output
no no yes no no no
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define LL long long
#define N 1000010
LL f[N];
int main()
{
int n;
LL a,b;
f[0]=7%3,f[1]=11%3;
while(~scanf("%d",&n))
{
for(int i=2; i<=n; i++)
f[i]=(f[i-2]+f[i-1])%3;
if(f[n]) printf("no\n");
else printf("yes\n");
}
return 0;
}