hdu 1021 Fibonacci Again(斐波那契数列,取余)

本文探讨了ACM问题HDU 1021中关于斐波那契数列与取余操作的关系,通过代码展示如何利用数论技巧优化计算过程。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51621    Accepted Submission(s): 24423


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
  
  
0 1 2 3 4 5
 

Sample Output
  
  
no no yes no no no
思路:边计算边取余即可,取余之后贡献值0,1,2不会改变

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define LL long long
#define N  1000010
LL f[N];
int main()
{
    int n;
    LL a,b;
    f[0]=7%3,f[1]=11%3;
    while(~scanf("%d",&n))
    {
        for(int i=2; i<=n; i++)
            f[i]=(f[i-2]+f[i-1])%3;
            if(f[n]) printf("no\n");
            else printf("yes\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值