The decimal expansion of the fraction 1/33 is 0.03, where the 03 is used to indicate that the cycle 03repeats indefinitely with no intervening digits. In fact, the decimal expansion of every rational number(fraction) has a repeating cycle as opposed to decimal expansions of irrational numbers, which have nosuch repeating cycles.
Examples of decimal expansions of rational numbers and their repeating cycles are shown below.Here, we use parentheses to enclose the repeating cycle rather than place a bar over the cycle.
Write a program that reads numerators and denominators of fractions and determines their repeatingcycles.
For the purposes of this problem, define a repeating cycle of a fraction to be the first minimal lengthstring of digits to the right of the decimal that repeats indefinitely with no intervening digits. Thusfor example, the repeating cycle of the fraction 1/250 is 0, which begins at position 4 (as opposed to 0which begins at positions 1 or 2 and as opposed to 00 which begins at positions 1 or 4).
Input
Each line of the input file consists of an integer numerator, which is nonnegative, followed by an integerdenominator, which is positive. None of the input integers exceeds 3000. End-of-file indicates the endof input.
Output
For each line of input, print the fraction, its decimal expansion through the first occurrence of the cycleto the right of the decimal or 50 decimal places (whichever comes first), and the length of the entirerepeating cycle.
In writing the decimal expansion, enclose the repeating cycle in parentheses when possible. If theentire repeating cycle does not occur within the first 50 places, place a left parenthesis where the cyclebegins — it will begin within the first 50 places — and place ‘…)’ after the 50th digit.
Sample Input
76 25
5 43
1 397
Sample Output
76/25 = 3.04(0)
1 = number of digits in repeating cycle
5/43 = 0.(116279069767441860465)
21 = number of digits in repeating cycle
1/397 = 0.(00251889168765743073047858942065491183879093198992…)
99 = number of digits in repeating cycle
思路:用数组存储:除数对应的循环小数位置、余数、除数
参考:http://blog.youkuaiyun.com/mobius_strip/article/details/39870555
欢迎交流:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
int main(){
int r[3005],s[3005],u[3005];
int n,m,t;
while(scanf("%d%d",&n,&m)!=EOF){
memset(r,0,sizeof(r));
memset(u,0,sizeof(u));
int cnt=0;
int t=n;
r[cnt++]=n/m;///小数点以前的数值
n=n%m;///计算余数
while(!u[n]&&n){//!u[n]在我看来是想求循环节的长度,就是求一个相同的余数出现的次数是否超过两次
u[n]=cnt;//存除数对应的循环小数位置,为了找到循环节的长度///
s[cnt]=n;///存循环小数位置对应的除数,为了找到循环节的开始位置输出(
r[cnt++]=10*n/m;///得到余数
n=n*10%m;///得到新除数
}
printf("%d / %d = %d",t,m,r[0]);
printf(".");
for(int i=1;i<cnt&&i<=50;i++){
if(s[i]==n)printf("(");
printf("%d",r[i]);
}
if(cnt>50)printf("...");
if(!n)printf("0");
printf(")\n");
printf(" %d = number of digits in repeating cycle",!n?1:cnt-u[n]);
}
return 0;
}