Rightmost Digit

本文介绍了一个算法,用于求解正整数N的N次方后的最右侧数字。通过分析不同个位数的幂次规律,使用switch-case结构实现了高效计算。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

 
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the rightmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
7
6


      
      
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

<code>

#include<stdio.h>
void main()
{ int i,N,j;
  scanf("%d",&i);
  while(i--)
  { scanf("%d",&N);
    switch(N%10)
 { case 0: j=0; break;
 case 1: j=1; break;
 case 2:  switch(N%4)
   { case 0: j=6;break;
           case 2: j=4;break;
   } break;  
 case 3: switch(N%4)
     {case 0: j=1;break;
         case 1: j=3;break;
         case 2: j=9;break;
         case 3: j=7;break;
   } break;
 case 4: j=6;break;
 case 5: j=5;break;
    case 6: j=6;break;
 case 7: switch(N%4)
     {
         case 1: j=7;break;
         case 3: j=3;break;
     }break;
 case 8: switch(N%4)
     {
         case 2: j=4;break;
         case 0: j=6;break;
     }break;
 case 9: j=9;break;
 }
 printf("%d\n",j);
  }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值