hdu 1019 Least Common Multiple(LCM的运用)

 

Problem Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105. 

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input

 

2 3 5 7 15 6 4 10296 936 1287 792 1

Sample Output

 

105 10296

水题:  求最小公倍数,其实就是两数相乘,然后乘以最大公因数。

 

 

           最大公倍数与某个数的最大公倍数还是原本的最大公倍数不会共边

           所以对于这题多个数字来说,我们两个两个算就好了。过程中可能会爆int,所以还是开long long 好点

           那我想到的处理方法就是先接受第一个数字,然后不断输入下一个数,每输入一个数运算一次。

 完整代码如下:

#include <iostream>
#include <queue>
#include <string.h>
#include <string>
#include <algorithm>
#include <map>
#include <cstdio>
using namespace std;
long long int zxgbs(long long int a,long long int b)
{
    if(a>b)
    return zxgbs(b,a);
    else
    {
      if(b%a==0)
        return a;
        return zxgbs(b%a,a);
    }
}
int main()
{
   long long  int cas,num,a,b,i,j;
  // cout<<"s";
    cin>>cas;
    while(cas--)
    {
        cin>>num;
        cin>>a;
        num--;
        while(num--)
        {
            cin>>b;
            j=zxgbs(a,b);
            //cout<<j<<endl;
            a=a*b/j;
        }
        cout<<a<<endl;
    }
    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值