ZCMU-Jolly Jumpers

A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance,

1 4 2 3

is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.

Each line of input contains an integer n < 3000 followed by n integers representing the sequence. For each line of input, generate a line of output saying "Jolly" or "Not jolly".

Input

Output

Sample Input

4 1 4 2 3
5 1 4 2 -1 6

Sample Output

Jolly
Not jolly
【解析】
这道题的意思就是两个连续的数,相差的元素要在1到n-1当中,而且必须都在1到n-1当中,否则就不行,所以我们
就要开一个数组记录一下,还要开一个标记,如果有不在1到n-1当中的就直接输出not jolly了,否则就比较是不是
1到n-1的元素都有了,如果都有了那就输出jolly。这里注意有重复的元素就不行。
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
int f[10010];
int main()
{
    int t,a,flag,b,i,c;
    while(~scanf("%d",&t))
    {
        flag=0;
        memset(f,0,sizeof(f));
        scanf("%d",&a);
        for(i=0;i<t-1;i++)
        {
            scanf("%d",&b);
            if(abs(a-b)<=t-1&&abs(a-b)>=1)//判断是不是在这个范围内
            {
                c=abs(a-b);
                if(f[c]==0)
                    f[c]=1;
                else
                    flag=1;//有重复的元素也不行
            }
            else//不在这个范围内就标记为1
            {
                flag=1;
            }
            a=b;
        }
        for(i=1;i<t-1&&flag==0;i++)/*判断是否在这个区间内都有
       并且没有重复的*/
        {
            if(f[i]==0)
            {
                flag=1;
                break;
            }
        }
        if(flag==0)
        {
            printf("Jolly\n");
        }
        else
        {
            printf("Not jolly\n");
        }
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值