LightOJ - 1282 Leading and Trailing(前三位和后三位)

本文介绍了一种求解特定幂次方数前后三位的有效算法。通过快速幂运算和对数计算,解决大数幂次方的问题,适用于竞赛编程。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231)and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

题目大意:对于给的数一个啊,一个b,求a的b次方的前三位数,和后三位数。

思路:对于后三位直接使用快速幂运算,对1000取余即可,对于前三位,任意数都可以用10的w次方进行表示。详细看代码。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define ll long long
ll mod_pow(ll x,ll n)//
{
    ll res=1;
    while(n>0)
    {
        if(n&1)
            res=res*x%1000;
        x=x*x%1000;
        n>>=1;
    }
    return res;
}
int main()
{
    int o=1;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        ll n,k;
        scanf("%lld%lld",&n,&k);
        ll ans1,ans2;
        double w;
        w=k*log10(n);//10的w次方==n的k次方,两边同时取log10
        w=w-(ll)w;//取w的小数部分
        ans1=(ll)pow(10,w+2);//10的w次方,w<0,所得的数应该>=1,所以再乘100
        ans2=mod_pow(n,k);//后三位
        printf("Case %d: %lld %03lld\n",o++,ans1,ans2);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值