Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,
Score of a bamboo = Φ (bamboo's length)
(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.
The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.
Input
Input starts with an integer T (≤ 100), denoting the number of test cases.
Each case starts with a line containing an integer n (1 ≤ n ≤ 10000)denoting the number of students of Phi-shoe. The next line contains nspace separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].
Output
For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.
Sample Input
3
5
1 2 3 4 5
6
10 11 12 13 14 15
2
1 1
Sample Output
Case 1: 22 Xukha
Case 2: 88 Xukha
Case 3: 4 Xukha
题目大意:一个竹竿长度为p,它的score值就是比p长度小且与且与p互质的数字总数,比如9有1,2,4,5,7,8这六个数那它的score就是6。
每个学生都有一个幸运数字,要求买回来的竹子的score值能>=学生的幸运数字,每个竹子的长度就是花费,求最小花费。
思路:欧拉函数的性质:如果一个数是质数(n),那它的欧拉函数值为n-1。所以只要求出大于每个幸运数字的第一个素数。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long
int a[10010];
int su[1000010];
void prime()
{
memset(su,0,sizeof(su));
su[2]=0;//*********
int i,j;
for(i=2; i*i<=1000100; i++)
{
for(j=i*2; j<=1000100; j+=i)
su[j]=1;
}
}
int main()
{
int t;
prime();
int o=1;
scanf("%d",&t);
while(t--)
{
int n;
memset(a,0,sizeof(a));
scanf("%d",&n);
for(int i=0; i<n; i++)
scanf("%d",&a[i]);
ll ans=0;
for(int i=0; i<n; i++)
{
for(int j=a[i]+1;; j++)
{
if(!su[j])
{
ans+=j;
break;
}
}
}
printf("Case %d: %lld Xukha\n",o++,ans);
}
return 0;
}