A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.
In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.
In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.
In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.
Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
Output
For each test case print a single line specifying the corresponding postorder sequence.
Sample Input
9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6
Sample Output
7 4 2 8 9 5 6 3 1
题目大意:知道一棵树的前序和中序,输出后序。
思路:前序的遍历方式:根->左->右,中序的遍历为左->根->右,在前序中从前向后进行遍历,在中序中找到根在的位置,从而判断当前的左右子树,递归的过程完成左子树,然后回溯的过程完成右子树。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[1010],b[1010];
struct node
{
int data;
node *lson,*rson;
node()//构造函数
{
lson=NULL;
rson=NULL;
}
};
node *inser(int *s1,int *s2,int l)
{
if(l<=0)
return NULL;
//易错,要先开新空间
node *root=new node();//**************
root->data=*s1;
int *p;
for(p=s2; p!=NULL; p++)
{
if(*p==*s1)
break;
}//左子树的长度
int kk=p-s2;
root->lson=inser(s1+1,s2,kk);//访问左子树
root->rson=inser(s1+kk+1,p+1,l-kk-1);//访问右子树
return root;//返回找到的节点
}
int flag;
void out(node *root)
{
if(root==NULL)
return ;
out(root->lson);
out(root->rson);
if(flag)
printf("%d",root->data);
else
printf(" %d",root->data);
flag=0;
}
int main()
{
int n;
while(~scanf("%d",&n))
{
flag=1;
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
for(int i=0; i<n; i++)
scanf("%d",&a[i]);
for(int j=0; j<n; j++)
scanf("%d",&b[j]);
node *root=new node();
root=inser(a,b,n);//************
out(root);
printf("\n");
}
return 0;
}