HDU-1710 Binary Tree Traversals (知前中推后)

A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2. 

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder. 

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder. 

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r. 

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence. 

Input

The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree. 

Output

For each test case print a single line specifying the corresponding postorder sequence. 

Sample Input

9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6

Sample Output

7 4 2 8 9 5 6 3 1

 

题目大意:知道一棵树的前序和中序,输出后序。

思路:前序的遍历方式:根->左->右,中序的遍历为左->根->右,在前序中从前向后进行遍历,在中序中找到根在的位置,从而判断当前的左右子树,递归的过程完成左子树,然后回溯的过程完成右子树。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[1010],b[1010];
struct node
{
    int data;
    node *lson,*rson;
    node()//构造函数
    {
        lson=NULL;
        rson=NULL;
    }
};
node *inser(int *s1,int *s2,int l)
{
    if(l<=0)
        return NULL;
    //易错,要先开新空间
    node *root=new node();//**************
    root->data=*s1;
    int *p;
    for(p=s2; p!=NULL; p++)
    {
        if(*p==*s1)
            break;
    }//左子树的长度
    int kk=p-s2;
    root->lson=inser(s1+1,s2,kk);//访问左子树
    root->rson=inser(s1+kk+1,p+1,l-kk-1);//访问右子树
    return root;//返回找到的节点
}
int flag;
void out(node *root)
{
    if(root==NULL)
        return ;
    out(root->lson);
    out(root->rson);
    if(flag)
        printf("%d",root->data);
    else
        printf(" %d",root->data);
    flag=0;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        flag=1;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        for(int j=0; j<n; j++)
            scanf("%d",&b[j]);
        node *root=new node();
        root=inser(a,b,n);//************
        out(root);
        printf("\n");
    }
    return 0;
}

 

内容概要:该论文研究了一种基于行波理论的输电线路故障诊断方法。当输电线路发生故障时,故障点会产生向两侧传播的电流和电压行波。通过相模变换对三相电流行波解耦,利用解耦后独立模量间的关系确定故障类型和相别,再采用小波变换模极大值法标定行波波头,从而计算故障点距离。仿真结果表明,该方法能准确识别故障类型和相别,并对故障点定位具有高精度。研究使用MATLAB进行仿真验证,为输电线路故障诊断提供了有效解决方案。文中详细介绍了三相电流信号生成、相模变换(Clarke变换)、小波变换波头检测、故障诊断主流程以及结果可视化等步骤,并通过多个实例验证了方法的有效性和准确性。 适合人群:具备一定电力系统基础识和编程能力的专业人士,特别是从事电力系统保护与控制领域的工程师和技术人员。 使用场景及目标:①适用于电力系统的故障检测与诊断;②能够快速准确地识别输电线路的故障类型、相别及故障点位置;③为电力系统的安全稳定运行提供技术支持,减少停电时间和损失。 其他说明:该方法不仅在理论上进行了深入探讨,还提供了完整的Python代码实现,便于读者理解和实践。此外,文中还讨论了行波理论的核心公式、三相线路行波解耦、行波测距实现等关键技术点,并针对工程应用给出了注意事项,如波速校准、采样率要求、噪声处理等。这使得该方法不仅具有学术价值,也具有很强的实际应用景。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值