1101 Quick Sort (25 分)
There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?
For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:
- 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
- 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
- 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
- and for the similar reason, 4 and 5 could also be the pivot.
Hence in total there are 3 pivot candidates.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.
Output Specification:
For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
Sample Input:
5
1 3 2 4 5
Sample Output:
3
1 4 5
Analysis
个人觉得这道题是我PAT甲级排序题做下来最坑的。题目要求找 pivot
,我首先想到的方法就遍历数组,然后判断当前点左侧是不是都小于,右侧是不是都大于,复杂度是 O(n2)。结果有的测试点超时了。
然后就换另一种方法:把读入的数组排好序,前后位置不变的就是 pivot
。这里会产生一个问题,就是如果左右侧大于和小于的情况相等的时候,比如:5 2 3 1 4这样这个3就会被误判。所以我们需要一个变量去记录左侧的最大值,只有同时满足左侧最大值也小于当前点的时候,当前点才是 pivot
。
整体而言题目难度不是很大,但是需要思考的地方很多。
Code(C++)
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
int n;
cin >> n;
int a[n], b[n];
for(int i=0; i<n; i++)
{
cin >> a[i];
b[i] = a[i];
}
sort(b, b+n);
int cnt = 0, res[n], max = -1;
for(int k=0; k<n; k++)
{
if(a[k] == b[k] && a[k] > max)
res[cnt++] = a[k];
if(a[k] > max)
max = a[k];
}
cout << cnt << endl;
if(cnt == 0)
cout << endl;
for(int i=0; i<cnt; i++)
{
if(i)
cout << " ";
cout << res[i];
}
}