hdu 5050 Divided Land(JAVA大数)

解决一个涉及二进制数的最大公约数问题,通过使用Java的大数处理能力来找到两个二进制表示的矩形面积之间的最大公约数,进而确定最优的土地划分方案。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Divided Land

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1679    Accepted Submission(s): 702


Problem Description
It’s time to fight the local despots and redistribute the land. There is a rectangular piece of land granted from the government, whose length and width are both in binary form. As the mayor, you must segment the land into multiple squares of equal size for the villagers. What are required is there must be no any waste and each single segmented square land has as large area as possible. The width of the segmented square land is also binary.
 

Input
The first line of the input is T (1 ≤ T ≤ 100), which stands for the number of test cases you need to solve.

Each case contains two binary number represents the length L and the width W of given land. (0 < L, W ≤ 2 1000)
 

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then one number means the largest width of land that can be divided from input data. And it will be show in binary. Do not have any useless number or space.
 

Sample Input
 
 
3 10 100 100 110 10010 1100
 

Sample Output
 
 
Case #1: 10 Case #2: 10 Case #3: 110
 

Source
 

Recommend
hujie


题意:

给了两个二进制数,求两个数的最大公约数。

思路:

因为数字比较大,考虑JAVA大数。

代码:

import java.util.Scanner;
import java.util.function.BinaryOperator;
import java.math.*;
import java.util.Comparator;
public class Main{
    public static void main(String[] args){
    	Scanner s = new Scanner (System.in);
    	int t = s.nextInt();
    	for(int i=1;i<=t;i++){
    		String a1=new String ();
    		String a2=new String ();
    		a1=s.next();
    		a2=s.next();
    		BigInteger b1=new BigInteger(a1,2);
    		BigInteger b2=new BigInteger(a2,2);
    		b1.toString();
    		b2.toString();
    		BigInteger ans=b1.gcd(b2);		
    		System.out.println("Case #"+i+": "+ans.toString(2));
    	}
}
}


HDOJ 1443是一个经典的数学模拟题目,通常涉及到动态规划。它描述的是“石头剪刀布”游戏的变种,玩家可以选择石头、剪刀或布,对手随机出拳。你需要编写一个程序来计算在给定的游戏轮数下,玩家获胜的概率。 以下是一个简化版的Java代码示例,实现了基本的策略并计算概率。假设我们使用朴素的策略,即每次都选择随机动作: ```java import java.util.Random; public class HDU_1443 { public static final String[] moves = {"石", "剪", "布"}; public static double getWinProbability(int n, int playerWins, int opponentWins) { Random random = new Random(); int totalGames = n * 3; double winCount = 0; for (int i = 0; i < totalGames; i++) { int playerMove = random.nextInt(3); int opponentMove = random.nextInt(3); if ((playerMove == 0 && opponentMove == 1) || (playerMove == 1 && opponentMove == 2) || (playerMove == 2 && opponentMove == 0)) { winCount++; } } return (double) winCount / totalGames * (1 + playerWins - opponentWins); // 考虑初始胜率差 } public static void main(String[] args) { int rounds = 1000; // 游戏轮数 System.out.println("Player wins on average in " + rounds + " games: " + getWinProbability(rounds, 0, 0)); // 初始胜率为0,两者无优势 } } ``` 注意:这是一个非常简单直接的解决方案,并未包含所有可能的策略优化,比如针对对手可能采取的特定策略进行调整。对于HDOJ这样的比赛题,可能需要更高级的策略分析。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值