【poj 2773】 Happy 2006

Description

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006. 

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order. 

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output

Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5

Source

这题题意就是求第K个与m互质的数,首先若(a,m)=1则(a+t*m,m)=1(这是一个显然的结论,辗转相除一下就可以得到),由此可以得到每m个数中与m互质的数是固定数量的,这样就可以先用欧拉函数求出m以内与m互质的数的个数p,然后所求的第K个数就等价于第K% φ(m)个数,由于m<=1000000,所以剩下部分暴力即可,下面是程序:
#include<stdio.h>
#include<iostream>
#define ll long long
using namespace std;
ll eular(ll n){
	ll i,s=n;
	for(i=2;i*i<=n;i++){
		if(!(n%i)){
			s=s/i*(i-1);
			while(!(n%i)){
				n/=i;
			}
		}
	}
	if(n>1){
		s=s/n*(n-1);
	}
	return s;
}
int gcd(int a,int b){
	while(b){
		int t=a%b;
		a=b;
		b=t;
	}
	return a;
}
int main(){
	int n,k,t,i;
	ll s;
	while(~scanf("%d%d",&n,&k)){
		t=eular(n);
		s=n*((k-1)/t);
		k=(k-1)%t+1;
		for(i=1;k;i++){
			k-=(gcd(i,n)==1);
		}
		printf("%lld\n",s+i-1);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值