OJ: Agri-Net(最小生成树)

题目描述
Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.
输入
The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.
输出
For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.
样例输入:
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
样例输出:
28

主要用到最小生成树

#include <stdio.h>
#define inf 99999999
int N,e[101][101],dis[101],book[101],sum;
void Prime()
{
    int min,k;
    for(int i=1;i<=N;i++)
    {
        dis[i]=e[1][i];
        book[i]=0;
    }
    dis[1]=0;
    book[1]=1;
    for(int i=1;i<N;i++)
    {
        min=inf;
        for(int j=1;j<=N;j++)//在未访问的的节点中找到最短的边
        {
            if(book[j]==0&&dis[j]<min)
            {
                min=dis[j];
                k=j;
            }
        }
        sum+=min;
        book[k]=1;//已访问结点到该点的最短边找到,该点为最短边的端点,表记为1,即访问过
        for(int j=1;j<=N;j++)
        {
            if(book[j]==0&&dis[j]>e[k][j])
                dis[j]=e[k][j];//新纳入接点k到未访问结点的距离更短,就更新dis[j]的值为到节点j的最短边值
        }
    }
}
 
int main()
{
    while(scanf("%d",&N)!=EOF)
    {
        sum=0;
        for(int i=1;i<=N;i++)
            for(int j=1;j<=N;j++)
            {
                scanf("%d",&e[i][j]);
            }
            Prime();
            printf("%d\n",sum);
    }
    return 0;
 
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值