Turn the corner
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1906 Accepted Submission(s): 726
Problem Description
Mr. West bought a new car! So he is travelling around the city.
One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.
Can Mr. West go across the corner?
One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.
Can Mr. West go across the corner?

Input
Every line has four real numbers, x, y, l and w.
Proceed to the end of file.
Proceed to the end of file.
Output
If he can go across the corner, print "yes". Print "no" otherwise.
Sample Input
10 6 13.5 4 10 6 14.5 4
Sample Output
yes no
#include<stdio.h>
#include<string.h>
#include<math.h>
#define pi (3.14/2)
#define add 0.0001
int main()
{
double x,y,L,D,i;
bool judge;
while(scanf("%lf %lf %lf %lf",&x,&y,&L,&D)!=EOF)
{
for(i=0,judge=true;i<=pi;i+=add)
if(L*cos(i)-x*cos(i)/sin(i)+D/sin(i)>=y)
{
judge=false;
break;
}
if(judge)
printf("yes\n");
else
printf("no\n");
}
return 0;
}