洛谷 P2698 [USACO12MAR]花盆Flowerpot(抄)

该博客介绍了USACO竞赛中的一道题,即如何放置花盆以确保水滴在至少D秒的时间内落入,并求解最小的花盆宽度。博主提出使用单调队列的方法,通过枚举左端点并扫描右端点,维护区间内水滴高度的最大值和最小值,以满足时间差要求。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目描述

Farmer John has been having trouble making his plants grow, and needs your help to water them properly. You are given the locations of N raindrops (1 <= N <= 100,000) in the 2D plane, where y represents vertical height of the drop, and x represents its location over a 1D number line:

;

Each drop falls downward (towards the x axis) at a rate of 1 unit per second. You would like to place Farmer John's flowerpot of width W somewhere along the x axis so that the difference in time between the first raindrop to hit the flowerpot and the last raindrop to hit the flowerpot is at least some amount D (so that the flowers in the pot receive plenty of water). A drop of water that lands just on the edge of the flowerpot counts as hitting the flowerpot.

Given the value of D and the locations of the N raindrops, please compute the minimum possible value of W.

老板需要你帮忙浇花。给出N滴水的坐标,y表示水滴的高度,x表示它下落到x轴的位置。

每滴水以每秒1个单位长度的速度下落。你需要把花盆放在x轴上的某个位置,使得从被花盆接着的第1滴水开始,到被花盆接着的最后1滴水结束,之间的时间差至少为D。

我们认为,只要水滴落到x轴上,与花盆的边沿对齐,就认为被接住。给出N滴水的坐标和D的大小,请算出最小的花盆的宽度W。

输入输出格式

输入格式:

第一行2个整数 N 和 D。

第2.. N+1行每行2个整数,表示水滴的坐标(x,y)。

输出格式:

仅一行1个整数,表示最小的花盆的宽度。如果无法构造出足够宽的花盆,使得在D单位的时间接住满足要求的水滴,则输出-1。

输入输出样例

输入样例#1:
4 5
6 3
2 4
4 10
12 15
输出样例#1:
2

说明

【样例解释】

有4滴水, (6,3), (2,4), (4,10), (12,15).水滴必须用至少5秒时间落入花盆。花盆的宽度为2是必须且足够的。把花盆放在x=4..6的位置,它可以接到1和3水滴, 之间的时间差为10-3 = 7满足条件。

【数据范围】

40%的数据:1 ≤ N ≤ 1000,1 ≤ D ≤ 2000;

100%的数据:1 ≤ N ≤ 100000,1 ≤ D ≤ 1000000,0≤x,y≤106。



单调队列。

枚举左端点,向后扫右端点,同时用两个单调队列来维护区间中y的最大最小值,直到y满足条件为止。

——BY 牌爷 chaijing


#include<algorithm>
#include<iostream>
#include<cstdio>
using namespace std;
const int N=100005;
int n,d,mxy,mny,ans=1e9+7,lef[N],q_min[N],q_max[N];
struct node
{
	int x,y;
}a[N];
bool cmp(node c,node d)
{
	return c.x<d.x;
}
int main()
{
	scanf("%d%d",&n,&d);
	mny=1e9+7;
	for(int i=1;i<=n;i++)
		scanf("%d%d",&a[i].x,&a[i].y),mxy=max(mxy,a[i].y),mny=min(mny,a[i].y);
	sort(a+1,a+n+1,cmp);
	if(mxy-mny<d)
	{
		printf("-1\n");
		return 0;
	}
	int h_min=1,t_min=0,h_max=1,t_max=0,j=0;
	for(int i=1;i<=n;i++)
	{
		while(a[q_max[h_max]].y-a[q_min[h_min]].y<d)
		{
			j++;
			if(j>n)
			{
				printf("%d\n",ans);
				return 0;
			}
			while(h_max<=t_max&&a[j].y>=a[q_max[t_max]].y)
				t_max--;
			q_max[++t_max]=j;
			while(h_min<=t_min&&a[j].y<=a[q_min[t_min]].y)
				t_min--;
			q_min[++t_min]=j;
		}
		ans=min(ans,a[j].x-a[i].x);
		if(q_min[h_min]==i)
			h_min++;
		if(q_max[h_max]==i)
			h_max++;
	}
	printf("%d\n",ans);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值