POJ 2560 Freckles

博客介绍了如何解决POJ 2560问题,该问题要求通过连接给定坐标上的多个点来形成一个网络,目标是最小化连接所有点的直线总长度。博主提出这个问题可以视为寻找最小生成树,从而计算出网络的最短总距离。提供的样例输入和输出展示了具体的操作过程。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Description
In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad’s back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley’s engagement falls through.
Consider Dick’s back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.
Input
The first line contains 0 < n <= 100, the number of freckles on Dick’s back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.
Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.
Sample Input
3
1.0 1.0
2.0 2.0
2.0 4.0
Sample Output
3.41


题意:给出坐标,然后用最短的直线连n个点,使得每两个点之间有连线、不就是最小生成树求整个网络的最短距离么、、


#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int n,m,f[105];
double ans,x[105],y[105];
struct pnt
{
    int l,r;
    double val;
}a[10005];
bool cmp(pnt c,pnt d)
{
    return c.val<d.val;
}
int fnd(int x)
{
    if(f[x]!=x)
        f[x]=fnd(f[x]);
    return f[x];
}
double dis(int i,int j)
{
    return (x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]);
}
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        f[i]=i;
    for(int i=1;i<=n;i++)
        scanf("%lf%lf",&x[i],&y[i]);
    for(int i=1;i<=n;i++)
        for(int j=i+1;j<=n;j++)
        {
            m++;
            a[m].l=i;
            a[m].r=j;
            a[m].val=dis(i,j);
        }
    sort(a+1,a+m+1,cmp);
    for(int i=1;i<=m;i++)
        if(fnd(a[i].l)!=fnd(a[i].r))
        {
            f[fnd(a[i].l)]=fnd(a[i].r);
            ans+=sqrt(a[i].val);
        }
    printf("%.2f\n",ans);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值