Description
A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8
Sample Output
4
题目大意:求一个给定序列的最长上升子序列。
详见:传送门
然而:给定序列中可能有零,我忘了把b[0]设成负数wa了好多次。
#include<iostream>
#include<cstdio>
using namespace std;
int n,m,a[1005],b[1005];
int main()
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%d",a+i);
b[0]=-1;
for(int i=1;i<=n;i++)
{
if(a[i]>b[m])
b[++m]=a[i];
else
for(int j=1;j<=m;j++)
if(a[i]<=b[j])
{
b[j]=a[i];
break;
}
}
printf("%d\n",m);
return 0;
}