题目:
Prime Ring Problem
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 38251 Accepted Submission(s): 16926
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Note: the number of first circle should always be 1.

Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
Source
Recommend
JGShining
题意即,给定数字N,将1~N共N个数字排序,使得相邻两数之和为质数,求出所有符合的排序。
首先我们要求出20以内所有质数制成质数表,方便查询。
对于每次搜索,初始值一定为1(题目规定),第二位有(N-1)种选择,即从初始状态可DFS递推至(N-1)条分路。
对于每一条路,又可以有(N-2)种选择。为了减少复杂度,当我们发现待选的路径和上一位不满足加和为质数时,我们将对这条路进行剪枝。即直接break掉,溯回上一层重新选择。
最后输出所有可能即可。
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int data[25][25];
int ans[25];
int que[25], n, be;
int sim[20] = { 0, 2, 3, 5, 7, 11, 13, 17, 19 };
int finding(int a, int b)
{
for (size_t i = 2; i <= 8; i++)
{
if ((a + b) % i == 0 && (a + b) != i)//建立质数表
{
return 1;
}
}
return 0;
}
void fins()
{
for (size_t s = 1; s < 21; s++)
{
for (size_t i = 1; i < 21; i++)
{
if (!finding(s, i))//按层进行搜索
{
data[s][i] = 1;
}
}
}
}
void print()
{
for (size_t i = 0; i < n - 1; i++)
{
cout << que[i] << " ";//que数组用来存已选择的数字,确定满足条件后 按位输出
}
cout << que[n - 1];
cout << "\n";
}
void dfs(int s)
{
for (size_t i = 1; i <= n; i++)
{
if (data[s][i] == 1 && ans[i] == 0)
{
ans[i] = 1;
que[be] = i;
be++;
if (be == n)
{
if (data[i][1] == 1)
{
print();
}
}
else
{
dfs(i);
}
be--;
ans[i] = 0;
}
}
}
int main()
{
int cas = 1;
fins();
while (cin >> n)
{
cout << "Case " << cas << ":\n";
be = 0;
memset(ans, 0, sizeof(ans));
memset(que, 0, sizeof(que));
ans[1] = 1;
que[be] = 1;
be++;
dfs(1);
cout << "\n";
cas++;
}
}