1119. Pre- and Post-order Traversals (30)【已知前序和后序求中序】

1119. Pre- and Post-order Traversals (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Special
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line "Yes" if the tree is unique, or "No" if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:
7
1 2 3 4 6 7 5
2 6 7 4 5 3 1
Sample Output 1:
Yes
2 1 6 4 7 3 5
Sample Input 2:
4
1 2 3 4
2 4 3 1
Sample Output 2:
No
2 1 3 4


#include <bits/stdc++.h>
#include<vector>
#define ms(x,y) memset(x,y,sizeof(x))
const int M=1e3+10;
using namespace std;
int i,j,k,n,m;
vector<int> pre,post,in;
int flag=1;

void getin(int prel,int prer,int posl,int posr)
{
    if(prel==prer){
      in.push_back(pre[prel]);
      return ;
    }
    if(pre[prel]==post[posr]){
     int i=prel+1;
     while(i<=prer&&pre[i]!=post[posr-1])i++;
     if(i-prel>1){
       getin(prel+1,i-1,posl,posl+i-prel-1-1);
     }
     else flag=0;
     in.push_back(post[posr]);
     getin(i,prer,posl+i-prel-1,posr-1);
    }
}

int main()
{
    scanf("%d",&n);
    pre.resize(n+1);post.resize(n+1);
    for(int i=1;i<=n;i++)scanf("%d",&pre[i]);
    for(int i=1;i<=n;i++)scanf("%d",&post[i]);
    getin(1,n,1,n);
    printf("%s\n%d",flag==1?"Yes":"No",in[0]);
    for(int i=1;i<in.size();i++)
        printf(" %d",in[i]);
        printf("\n");
    return 0;
}

内容概要:本文深入探讨了多种高级格兰杰因果检验方法,包括非线性格兰杰因果检验、分位数格兰杰因果检验、混频格兰杰因果检验以及频域因果检验。每种方法都有其独特之处,适用于不同类型的时间列数据。非线性格兰杰因果检验分为非参数方法、双变量多元检验,能够在不假设数据分布的情况下处理复杂的关系。分位数格兰杰因果检验则关注不同分位数下的因果关系,尤其适合经济数据的研究。混频格兰杰因果检验解决了不同频率数据之间的因果关系分析问题,而频域因果检验则专注于不同频率成分下的因果关系。文中还提供了具体的PythonR代码示例,帮助读者理解应用这些方法。 适合人群:从事时间列分析、经济学、金融学等领域研究的专业人士,尤其是对非线性因果关系感兴趣的学者技术人员。 使用场景及目标:①研究复杂非线性时间列数据中的因果关系;②分析不同分位数下的经济变量因果关系;③处理不同频率数据的因果关系;④识别特定频率成分下的因果关系。通过这些方法,研究人员可以获得更全面、细致的因果关系洞察。 阅读建议:由于涉及较多数学公式编程代码,建议读者具备一定的统计学编程基础,特别是对时间列分析有一定了解。同时,建议结合具体案例进行实践操作,以便更好地掌握这些方法的实际应用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值