Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 12352 | Accepted: 4318 |
Description
In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be
.
Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.
Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes
.
Input
The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.
Output
For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.
Sample Input
3 1 5 0 2 5 1 6 4 2 1 2 7 9 5 6 7 9 0 0
Sample Output
83 100
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;
#define ll long long
#define ms(a,b) memset(a,b,sizeof(a))
const int M=1e5+10;
const int inf=0x3f3f3f3f;
const int mod=1e9+7;
int i,j,k,n,m;
int a[M];
int b[M];
double y[M];
bool cmp(double a,double b)
{
return a>b;
}
bool check(double mid)
{
for(int i=0;i<n;i++)
y[i]=a[i]-b[i]*mid;
sort(y,y+n,cmp);
double sum=0;
for(int i=0;i<n-k;i++)
sum+=y[i];
return sum>=0;
}
int main()
{
while(~scanf("%d%d",&n,&k)){
if(n==0&&k==0)break;
for(int i=0;i<n;i++)scanf("%d",&a[i]);
for(int i=0;i<n;i++)scanf("%d",&b[i]);
double lb=0,ub=1000000000;
for(int i=0;i<100;i++){
double mid=(lb+ub)/2;
if(check(mid))lb=mid;
else ub=mid;
}
printf("%.0lf\n",ub*100);
}
return 0;
}