HDU 1198 Farm Irrigation

Farm Irrigation

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 33   Accepted Submission(s) : 21
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


Figure 1


Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 

ADC
FJK
IHE

then the water pipes are distributed like 


Figure 2


Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output

For each test case, output in one line the least number of wellsprings needed.

Sample Input

2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

Sample Output

2
3

Author

ZHENG, Lu

Source

Zhejiang University Local Contest 2005
合并之前先判断是否能连通,若能连通则合并,不能连通,则不能合并。
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define MS(x,y)memset(x,y,sizeof(x))
typedef long long LL;
const int INF=0x7ffffff;

const int M=50+1;
//将二维坐标转换成一维的标号,此处用行优先
int pre[M*M+1];
char farm[M][M];
int i,j,k,n,m,cnt;
//存储11中类型的土地,二维中的0 1 2 3分别代表这种类型的土地的左上右下
//为1表示这个方向有接口,为0表示这个方向没有接口
int type[11][4]={{1,0,1,0},{1,0,0,1},
                 {0,1,1,0},{0,1,0,1},
                 {1,1,0,0},{0,0,1,1},
                 {1,0,1,1},{1,1,1,0},
                 {0,1,1,1},{1,1,0,1},
                 {1,1,1,1}

};

void init(int n)
{
    rep(i,0,n+1)
       pre[i]=i;
}

int root(int x)
{
    if(x!=pre[x])
        pre[x]=root(pre[x]);
    return pre[x];
}

void combine(int sx,int sy,int ex,int ey,int dir)
{
    if(ex>n||ey>m)return;
    bool mark=false;
    int ta=farm[sx][sy]-'A';
    int tb=farm[ex][ey]-'A';
    if(dir)
        {if(type[ta][3]&&type[tb][2])mark=true;}
    else {if(type[ta][1]&&type[tb][0])mark=true;}
    if(mark){
        int fx=root((sx-1)*m+sy);
         int fy=root((ex-1)*m+ey);
         if(fx!=fy)pre[fx]=fy,--cnt;
    }

}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==-1&&m==-1)break;
        init(n*m);
        rep(i,1,n+1)scanf("%s",farm[i]+1);
        cnt=n*m;
        rep(i,1,n+1)
          rep(j,1,m+1){
            combine(i,j,i+1,j,0);
            combine(i,j,i,j+1,1);
          }
        printf("%d\n",cnt);
    }
    return 0;
}


内容概要:本文深入探讨了多种高级格兰杰因果检验方法,包括非线性格兰杰因果检验、分位数格兰杰因果检验、混频格兰杰因果检验以及频域因果检验。每种方法都有其独特之处,适用于不同类型的时间序列数据。非线性格兰杰因果检验分为非参数方法、双变量和多元检验,能够在不假设数据分布的情况下处理复杂的关系。分位数格兰杰因果检验则关注不同分位数下的因果关系,尤其适合经济数据的研究。混频格兰杰因果检验解决了不同频率数据之间的因果关系分析问题,而频域因果检验则专注于不同频率成分下的因果关系。文中还提供了具体的Python和R代码示例,帮助读者理解和应用这些方法。 适合人群:从事时间序列分析、经济学、金融学等领域研究的专业人士,尤其是对非线性因果关系感兴趣的学者和技术人员。 使用场景及目标:①研究复杂非线性时间序列数据中的因果关系;②分析不同分位数下的经济变量因果关系;③处理不同频率数据的因果关系;④识别特定频率成分下的因果关系。通过这些方法,研究人员可以获得更全面、细致的因果关系洞察。 阅读建议:由于涉及较多数学公式和编程代码,建议读者具备一定的统计学和编程基础,特别是对时间序列分析有一定了解。同时,建议结合具体案例进行实践操作,以便更好地掌握这些方法的实际应用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值