L2-012 关于堆的判断

L2-012 关于堆的判断

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

x is the root:x是根结点;
x and y are siblings:x和y是兄弟结点;
x is the parent of y:x是y的父结点;
x is a child of y:x是y的一个子结点。
输入格式:
每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:
对输入的每个命题,如果其为真,则在一行中输出T,否则输出F。

输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:
F
T
F
T

注意这题神坑,仔细审题的话会发现题目是要求你在初始化为空的小顶堆里插入结点,而不是在输入完成后进行堆排序,两者的顺序是不一样的

#include <vector>
#include <string>
#include <iostream>
#include <unordered_map>
using namespace std;
static const auto io_sync_off = []() {
    std::ios::sync_with_stdio(false);
    std::cin.tie(nullptr);
    return nullptr;
}();

vector<int> nums;


// 下面的注释是堆排序,输入完成后调用heap_sort(n),就可以对数组进行
// 堆排序 ,先看怎么向下调整再看怎么向上调整,这样好理解
/* void siftdown(int i,int n)  //向下调整
{
    int t=nums[i],j;
    while((j=2*i+1)<n)
    {
        if(j<n-1&&nums[j]<nums[j+1]) ++j;
        if(t<nums[j])
        {
            nums[i]=nums[j];
            i=j;
        }
        else break;
    }
    nums[i]=t;
}

 void heap_sort(int n)       //堆排序
{
    for(int i=(n-2)/2;i>=0;--i) 
        siftdown(i,n);
    for(int i=n-1;i>0;--i)
    {
        swap(nums[0],nums[i]);
        siftdown(0,i);
    }
} */

void siftup(int k) //向上调整,结点插入的位置为k
{
    int j = k, i = (j - 1) / 2; //i是k的父亲节点
    int t = nums[j];
    while (j > 0) //j不是根节点时
    {
        if (nums[i] < t)
            break;
        else
        {
            nums[j] = nums[i];
            j = i;
            i = (i - 1) / 2;
        }
    }
    nums[j] = t;
}

int main()
{
    int n, m;
    cin >> n >> m;
    nums.resize(n);
    for (int i = 0; i < n; ++i)
    {
        cin >> nums[i];
        siftup(i);
    }
    string str;
    unordered_map<int, int> hash;
    for (int i = 0; i < n; ++i)//记录每个点的位置
        hash[nums[i]] = i;
    
    for (int i = 0; i < m; ++i)
    {
        int x, y, index_x, index_y;
        cin >> x;
        cin >> str;
        index_x = hash[x];
        if (str[0] == 'a')
        {
            cin >> y;
            getline(cin, str);
            index_y = hash[y];
            if ((index_x - 1) / 2 == (index_y - 1) / 2)
                cout << "T" << endl;
            else
                cout << "F" << endl;
        }
        else
        {
            cin >> str;
            cin >> str;
            if (str[0] == 'r')
            {
                if (index_x == 0)
                    cout << "T" << endl;
                else
                    cout << "F" << endl;
            }
            else if (str[0] == 'p')
            {
                cin >> str;
                cin >> y;
                index_y = hash[y];
                if ((index_y - 1) / 2 == index_x)
                    cout << "T" << endl;
                else
                    cout << "F" << endl;
            }
            else
            {
                cin >> str;
                cin >> y;
                index_y = hash[y];
                if ((index_x - 1) / 2 == index_y)
                    cout << "T" << endl;
                else
                    cout << "F" << endl;
            }
        }
    }
    return 0;
}
### 关于的数据结构判断问题及其Java实现 #### 定义与特性 是一种特殊的完全二叉树,分为最大和最小两种形式。对于最大而言,任意节点的键值总是大于等于其子节点的键值;而对于最小,则相反,即任意节点的键值小于等于其子节点的键值[^1]。 #### PTA L2-012 判断逻辑解析 针对L2-012中的具体需求,程序需接收一组整数作为输入并构建相应的最小或最大(取决于题目要求),之后依据特定条件验证若干命题的真实性。这些命题涉及根节点、兄弟关系、父子关系等方面的内容[^4]。 #### Java代码实例展示 下面给出一段用于解决上述问题的核心部分——向已有的最小插入新元素,并提供辅助函数来执行各种类型的查询: ```java import java.util.*; public class MinHeap { private List<Integer> heap; public MinHeap() { this.heap = new ArrayList<>(); // 初始化时加入哨兵元素以便简化索引计算 this.heap.add(Integer.MIN_VALUE); } /** * 向最小内添加新的数值 */ public void insert(int value){ int index = heap.size(); heap.add(value); while (index / 2 > 0 && heap.get(index/2) > heap.get(index)){ swap(index, index/2); index /= 2; } } /** * 获取指定位置处的左孩子下标 */ private static int getLeftChildIndex(int parentIndex){ return parentIndex*2; } /** * 获取指定位置处的右孩子下标 */ private static int getRightChildIndex(int parentIndex){ return parentIndex*2 + 1; } /** * 判断两个给定的位置是否互为兄弟节点 */ public boolean areSiblings(int x, int y){ if(x <= 0 || y <= 0 || x >= heap.size() || y >= heap.size()) throw new IndexOutOfBoundsException(); return getParentIndex(x)==getParentIndex(y)&&x!=y; } /** * 返回某节点的父亲节点所在数组里的序号 */ private static int getParentIndex(int childIndex){ return childIndex/2; } /** * 查询某个数字是不是当前顶元素 */ public boolean isRoot(int target){ return !heap.isEmpty()&&target==heap.get(1); } /** * 验证是否存在这样的亲子关系:parent->child */ public boolean hasParentChildRelation(int parent,int child){ if(child<=0||parent<=0||child>=heap.size()||parent>=heap.size()) throw new IndexOutOfBoundsException(); return getParentIndex(child)==parent; } /** * 执行交换操作 */ private void swap(int i, int j){ Collections.swap(heap,i,j); } } ``` 这段代码实现了基本的小根功能,包括但不限于插入新成员、查找根节点、确认两节点间的关系等常用方法。通过调用`insert()`可以逐步建立起所需的结构,而其他几个公开的方法则可用于完成后续的各种检验工作。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值