description
Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:
registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
idea
- 考场内排名(部分排名)+全部考生排名(整体排名)
联想到借助结构体分别记录。
solution
#include <stdio.h>
#include <algorithm>
using namespace std;
struct student{
long long id;//10^18以内,long long完全carry
int score, c, f, l;//c考场 f最终排名 l考场内排名
}stu[30010];
bool cmp(student s1, student s2){
if(s1.score != s2.score) return s1.score > s2.score;//不同分数,高分数的高排名
else return s1.id < s2.id;//同分数,按学号从小到大
}
int main(){
int N, n, num = 0;
scanf("%d", &N);
for(int i = 1; i <= N; i++){//依次处理每个考场的考生
scanf("%d", &n);
for(int j = 0; j < n; j++){
scanf("%lld%d", &stu[num].id, &stu[num].score);
stu[num].c = i;
num++;
}
sort(stu + num - n, stu + num, cmp);//考场内排序
stu[num - n].l = 1;
for(int j = num - n + 1, k = 1; j < num; j++, k++){
if(stu[j].score != stu[j-1].score) stu[j].l = k + 1;
else stu[j].l = stu[j - 1].l;
}
}
sort(stu, stu + num, cmp);
stu[0].f = 1;
printf("%d\n%lld %d %d %d\n", num, stu[0].id, stu[0].f, stu[0].c, stu[0].l);
for(int i = 1; i < num; i++){
if(stu[i].score != stu[i - 1].score) stu[i].f = i + 1;
else stu[i].f = stu[i - 1].f;
printf("%lld %d %d %d", stu[i].id, stu[i].f, stu[i].c, stu[i].l);
if(i != num - 1) printf("\n");
}
return 0;
}
可以失望,但不能绝望。今天就是新的一天!