POJ 2253-Frogger(最小生成树-给定终点)

本文介绍了一个经典的最短路径问题——Frogger问题,通过Prim算法寻找两块石头间青蛙跳跃的最远距离,即所谓的青蛙距离。提供了解题思路及C++实现代码,并附带测试数据。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40659 Accepted: 13051

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source


题目意思:

给出N个青蛙的坐标Xi,Yi,青蛙编号1~N。

青蛙1要从自己的位置跳到青蛙2的位置,求路程中所有路径中最长的一条的长度。


解题思路:

套了个prim的模板,改动的地方是:一旦目标点2被加入且更新后,最小树构建完毕,直接跳出循环。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>
#define MAXN 1010
#define INF 0xfffffff//0X代表16进制,后面是数字,十进制是4294967295
using namespace std;
struct Node
{
    int x,y;//坐标
} po[MAXN];
double cost[MAXN][MAXN],dis[MAXN],mincost[MAXN];//权值、最短路、最小生成树
int n;
bool used[MAXN];//标识是否使用过

void prim()
{
    fill(mincost,mincost+n+1,INF);
    fill(used,used+n+1,false);
    mincost[0]=0;
    double Max=-1;
    while(true)
    {
        int v=-1;
        for(int u=1; u<=n; ++u)
        {
            //从不属于已加入生成树的顶点中选取从已加入生成树的点到该顶点的权值最小的点
            if(!used[u]&&(v==-1||mincost[u]<mincost[v]))
                v=u;
        }
        if(v==-1) break;
        used[v]=true;
        if(Max<mincost[v]&&mincost[v]!=INF)
            Max=mincost[v];
        if(v==2) break;//2被加入,结束
        for(int u=1; u<=n; ++u)
            if(mincost[u]>cost[v][u])
                mincost[u]=cost[v][u];
    }
    cout.precision(3);
    cout.setf(ios::fixed);
    cout<<"Frog Distance = "<<Max<<endl<<endl;
}

int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("F:/cb/read.txt","r",stdin);
    //freopen("F:/cb/out.txt","w",stdout);
#endif
    ios::sync_with_stdio(false);
    cin.tie(0);
    int ca=0;
    while(cin>>n&&n)
    {
        for(int i=0; i<=n; ++i)
            for(int j=0; j<=n; ++j)
                cost[i][j]=INF;//手动初始化,不能fill了……
        for(int i=1; i<=n; i++)
            cin>>po[i].x>>po[i].y;
        for(int i=1; i<n; i++)
            for(int j=i+1; j<=n; j++)
                cost[i][j]=cost[j][i]=sqrt((po[i].x-po[j].x)*(po[i].x-po[j].x)+(po[i].y-po[j].y)*(po[i].y-po[j].y));
        cout<<"Scenario #"<<++ca<<endl;
        prim();
    }
    return 0;
}
/*
3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0
*/

测试数据:

2
0 0
3 4

3
17 4
19 4
18 5
8
1 1
4 0
1 2
2 2
3 2
4 2
3 0
5 1
3
9 10
10 10
100 10
6
5 5
100 100
4 4
3 3
2 2
1 1
5
1 2
2 1
3 2
4 1
5 2
3
999 999
1 1
3 3
0

结果:
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Scenario #3
Frog Distance = 1.414

Scenario #4
Frog Distance = 1.000

Scenario #5
Frog Distance = 134.350

Scenario #6
Frog Distance = 1.414

Scenario #7
Frog Distance = 1408.557

感谢:yangyh,本测试用例为他所提供


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值