POJ-1405 Heritage-高精度加减乘

本文探讨了一个遗产分配问题,其中遗产需要在家庭成员和教会间公平分配,通过数学算法找到最优解,最小化教会获得的遗产份额。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Heritage
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7370 Accepted: 2743

Description

Your rich uncle died recently, and the heritage needs to be divided among your relatives and the church (your uncle insisted in his will that the church must get something). There are N relatives (N <= 18) that were mentioned in the will. They are sorted in descending order according to their importance (the first one is the most important). Since you are the computer scientist in the family, your relatives asked you to help them. They need help, because there are some blanks in the will left to be filled. Here is how the will looks:

Relative #1 will get 1 / ... of the whole heritage,
Relative #2 will get 1 / ... of the whole heritage,
---------------------- ...
Relative #n will get 1 / ... of the whole heritage.

The logical desire of the relatives is to fill the blanks in such way that the uncle's will is preserved (i.e the fractions are non-ascending and the church gets something) and the amount of heritage left for the church is minimized.

Input

The only line of input contains the single integer N (1 <= N <= 18).

Output

Output the numbers that the blanks need to be filled (on separate lines), so that the heritage left for the church is minimized.

Sample Input

2

Sample Output

2
3

Source

ural 1108

根据题目意思就是说,后一个人的分母N是前一个人的分母M进行M*(M-1)+1的计算所得。
然后用高精度加减乘就可以算出来~

#include<stdio.h>
#include<stdlib.h>
#define inf 1000000000
#define maxn 100000
int len1, len2, len3, len[18];
long long  a[maxn], b[maxn], ans[maxn], res[18][maxn];
void setAns()
{
    for (int i = 0; i < len3; i++)
    {
        ans[i] = 0;
    }
}
void copy()
{
    for (int i = 0; i < len3; i++)
    {
        a[i] = ans[i];
    }
    len1 = len3;
}
void multiply()
{
    int i, j;
    setAns();
    for (i = 0; i < len2; i++)
    {
        for (j = 0; j < len1; j++)
        {
            ans[i+j] += a[j] * b[i];
            ans[i+j+1] += ans[i+j] / inf;
            if (ans[i+j+1] && len3 <= i + j + 1)
            {
                len3 = i + j + 2;
            }
            else if (len3 <= i + j)
            {
                len3 = i + j + 1;
            }
            ans[i+j] %= inf;
        }
    }
}
void plus()
{
    int r;
    for (len2 = 0, r = 1; len2 < len1; len2++)
    {
        r += a[len2];
        if (r >= inf)
        {
            b[len2] = r - inf;
            r = 1;
        }
        else
        {
            b[len2] = r;
            r = 0;
        }
    }
    if (r)
    {
        b[len2++] = r;
    }
}
int main()
{
    int i, j, n;
    scanf("%d", &n);
    a[0] = 2;
    len1 = 1;
    printf("2\n");
    for (i = 2; i <= n; i++)
    {
        plus();
        printf("%lld", b[len2-1]);
        for (j = len2 - 2; j >= 0; j--)
        {
            printf("%.9lld", b[j]);
        }printf("\n");
        if (i < n)
        {
            multiply();
            copy();
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值