【poj2104】K-th Number 主席树

本文通过解决一个关于快速查找数组区间内第k小元素的问题,介绍了如何使用可持久化线段树进行高效的数据管理和查询。文章提供了两种实现方式:数组版和指针版,并附带完整的代码示例。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1…n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: “What would be the k-th number in a[i…j] segment, if this segment was sorted?”
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2…5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n — the size of the array, and m — the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 109 by their absolute values — the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it — the k-th number in sorted a[i…j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

Source

Northeastern Europe 2004, Northern Subregion


第三遍做这个题了…

第一遍写的超丑的分块:http://blog.youkuaiyun.com/loi_dqs/article/details/48580281

第二遍写的巨爽的归并树:http://blog.youkuaiyun.com/loi_dqs/article/details/49018237

然后现在学了可持久化线段树…抄了抄黄学长的代码然后自己改了个指针版…

数组版:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;

typedef long long LL;
const int SZ = 5000010;
const int INF = 1000000010;

int lsh[SZ];

struct segment{
    int l,r;
    int cnt;
}tree[SZ];

int Tcnt = 0;

int rt[SZ];

void insert(int l,int r,int x,int &y,int v)
{
    y = ++ Tcnt;
    tree[y] = tree[x];
    tree[y].cnt ++;
    if(l == r) return ;
    int mid = l + r >> 1;
    if(v <= mid) insert(l,mid,tree[x].l,tree[y].l,v);
    else insert(mid + 1,r,tree[x].r,tree[y].r,v);
}

int ask(int l,int r,int x,int y,int k)
{
    if(l == r) return l;
    int mid = l + r >> 1;
    if(tree[tree[y].l].cnt - tree[tree[x].l].cnt >= k) 
        return ask(l,mid,tree[x].l,tree[y].l,k);
    else 
        return ask(mid + 1,r,tree[x].r,tree[y].r,k - (tree[tree[y].l].cnt - tree[tree[x].l].cnt));
}

int num[SZ];

int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i = 1;i <= n;i ++)
    {
        scanf("%d",&num[i]);
        lsh[++ lsh[0]] = num[i];
    }
    sort(lsh + 1,lsh + 1 + lsh[0]);
    int len = unique(lsh + 1,lsh + 1 + lsh[0]) - lsh - 1;
    for(int i = 1;i <= n;i ++)
    {
        num[i] = lower_bound(lsh + 1,lsh + 1 + len,num[i]) - lsh;
        insert(1,len,rt[i - 1],rt[i],num[i]);
    }
    while(m --)
    {
        int l,r,k;
        scanf("%d%d%d",&l,&r,&k);
        printf("%d\n",lsh[ask(1,len,rt[l - 1],rt[r],k)]);
    }
    return 0;
}

指针版:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;

typedef long long LL;
const int SZ = 5000010;
const int INF = 1000000010;

int lsh[SZ];

struct node{
    node *ch[2];
    int cnt;
} *rt[SZ],T[SZ], *null;

int Tcnt = 0;

node* newnode()
{
    node *k = T + (Tcnt ++);
    k -> ch[0] = k -> ch[1] = null;
    k -> cnt = 0;
    return k;
}

void insert(int l,int r,node *x,node* &y,int v)
{
    y = newnode();
    y -> ch[0] = x -> ch[0]; y -> ch[1] = x -> ch[1];
    y -> cnt = x -> cnt + 1;
    if(l == r) return ;
    int mid = l + r >> 1;
    if(v <= mid) insert(l,mid,x -> ch[0],y -> ch[0],v);
    else insert(mid + 1,r,x -> ch[1],y -> ch[1],v);
}

int ask(int l,int r,node *x,node *y,int k)
{
    if(l == r) return l;
    int mid = l + r >> 1;
    if(y -> ch[0] -> cnt - x -> ch[0] -> cnt >= k) 
        return ask(l,mid,x -> ch[0],y -> ch[0],k);
    else 
        return ask(mid + 1,r,x -> ch[1],y -> ch[1],k - (y -> ch[0] -> cnt - x -> ch[0] -> cnt));
}

int num[SZ],n,m;

void init()
{
    null = newnode();
    null -> ch[0] = null -> ch[1] = null;
    rt[0] = null;   
}

int main()
{
    init();
    scanf("%d%d",&n,&m);
    for(int i = 1;i <= n;i ++)
    {
        scanf("%d",&num[i]);
        lsh[++ lsh[0]] = num[i];
    }
    sort(lsh + 1,lsh + 1 + lsh[0]);
    int len = unique(lsh + 1,lsh + 1 + lsh[0]) - lsh - 1;
    for(int i = 1;i <= n;i ++)
    {
        num[i] = lower_bound(lsh + 1,lsh + 1 + len,num[i]) - lsh;
        insert(1,len,rt[i - 1],rt[i],num[i]);
    }
    while(m --)
    {
        int l,r,k;
        scanf("%d%d%d",&l,&r,&k);
        printf("%d\n",lsh[ask(1,len,rt[l - 1],rt[r],k)]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值