1007 Maximum Subsequence Sum (25分)

1007 Maximum Subsequence Sum (25分)
Given a sequence of K integers { N​1, N2, …, N​K}. A continuous subsequence is defined to be { N​i, N​i+1, …, N​j} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:
10 1 4

本题直接使用动态规划即可。这里要注意一点,下方程序中我利用变量high来保存最大序列和的下标,然而当n=1时,并不会进入迭代的为dp数组赋值的循环语句,这就导致没有赋初值的变量high用于数组访问,发生段错误。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 10010;
int data[maxn];
int dp[maxn];
int main(){
    int n;
    scanf("%d",&n);
    int flag = 0;
    for(int i=0;i<n;i++){
        scanf("%d",&data[i]);
        if(data[i]>=0) flag = 1;
    }
    if(!flag){
    	printf("0 %d %d",data[0],data[n-1]);
    	return 0;
	}
    sum[0] = data[0];
    int m=-99999,high=0;
	for(int i=1;i<n;i++){
		dp[i] = max(data[i],data[i]+dp[i-1]);
		if(dp[i]>m){
			m = dp[i];
			high = i;
		}
	}
	int res = 0,low=0;
	for(int i=high;i>=0;i--){
		if(res+data[i] == dp[high]){
			low = i;
			break;
		}	
		res+=data[i];
	}
	printf("%d %d %d",dp[high],data[low],data[high]);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值