http://acm.hdu.edu.cn/showproblem.php?pid=1673
http://acm.hust.edu.cn/vjudge/contest/view.action?cid=29974#problem/E
Optimal Parking
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1268 Accepted Submission(s): 1081
Problem Description
When shopping on Long Street, Michael usually parks his car at some random location, and then walks to the stores he needs.
Can you help Michael choose a place to park which minimises the distance he needs to walk on his shopping round?
Long Street is a straight line, where all positions are integer.
You pay for parking in a specific slot, which is an integer position on Long Street. Michael does not want to pay for more than one parking though. He is very strong, and does not mind carrying all the bags around.
Input
The first line of input gives the number of test cases, 1 <= t <= 100. There are two lines for each test case. The first gives the number of stores Michael wants to visit, 1 <= n <= 20, and the second gives their n integer positions on Long Street, 0 <= xi <= 99.
Output
Output for each test case a line with the minimal distance Michael must walk given optimal parking.
Sample Input
2
4
24 13 89 37
6
7 30 41 14 39 42
Sample Output
152
70
Source
2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(3)
Recommend
lcy
解析:
题意:
一条街上有n个点,求要把每个点来回走一遍需要的最短路程
思路:水题
求出最远点和最近点之差乘2即可
228 KB 15 ms C++ 331 B
*/
#include<stdio.h>
#include<math.h>
#include <iostream>
using namespace std;
int main()
{
int T,n,i;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
int ans,mx,mi,x;
mx=0;
mi=100;
for(i=0;i<n;i++)
{
scanf("%d",&x);
if(x<mi)
mi=x;
if(x>mx)
mx=x;
}
ans=(mx-mi)*2;
printf("%d\n",ans);
}
return 0;
}