03-树2 List Leaves (25分)

本文介绍了一种树形数据结构中叶子节点的遍历算法,采用从上到下,从左到右的顺序输出所有叶子节点的索引。通过输入节点数量和其左右子节点信息,构建树形结构,然后利用队列实现广度优先搜索,最终输出符合要求的叶子节点序列。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

03-树2 List Leaves (25分)
Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:
For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -

0 -
2 7

5 -
4 6
Sample Output:
4 1 5

#include <iostream>
#include <queue>
using namespace std;
int n;
const int maxn = 15;
struct node
{
    int left, right, num;
} tree[maxn];
int vis[maxn];
void build()
{
    cin >> n;
    char a, b;
    for (int i = 0; i < n; i++)
    {
        cin >> a >> b;
        if (a == '-')
        {
            tree[i].left = -1;
        }
        else
            tree[i].left = a - '0';
        if (b == '-')
        {
            tree[i].right = -1;
        }
        else
            tree[i].right = b - '0';
        tree[i].num = i;
    }
}
int findroot()
{
    for (int i = 0; i < n; i++)
    {
        if (tree[i].left != -1)
            vis[tree[i].left] = 1;
        if (tree[i].right != -1)
            vis[tree[i].right] = 1;
    }
    int root;
    for (int i = 0; i < n; i++)
        if (!vis[i])
            root = i;
    return root;
}
int main()
{
    build();
    int flag = 0;
    int root = findroot();
    queue<node> q;
    q.push(tree[root]);
    while (!q.empty())
    {
        node u = q.front();
        q.pop();
        if (u.left != -1)
            q.push(tree[u.left]);
        if (u.right != -1)
            q.push(tree[u.right]);
        if (u.left == -1 && u.right == -1)
        {
            if (flag)
                cout << " ";
            flag = 1;
            cout << u.num;
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值