Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 3341 | Accepted: 1717 |
Description
We give the following inductive definition of a “regular brackets” sequence:
- the empty sequence is a regular brackets sequence,
- if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
- if a and b are regular brackets sequences, then ab is a regular brackets sequence.
- no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:
(), [], (()), ()[], ()[()]
while the following character sequences are not:
(, ], )(, ([)], ([(]
Given a brackets sequence of characters a1a2 …an, your goal is to find the length of the longest regular brackets sequence that is a subsequence ofs. That is, you wish to find the largest m such that for indicesi1, i2, …, im where 1 ≤i1 < i2 < … < im ≤ n, ai1ai2 …aim is a regular brackets sequence.
Given the initial sequence ([([]])]
, the longest regular brackets subsequence is[([])]
.
Input
The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters(
, )
, [
, and ]
; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.
Output
For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.
Sample Input
((())) ()()() ([]]) )[)( ([][][) end
Sample Output
6 6 4 0 6
Source
也是一道十分经典的区间dp题,我们用dp[i][j]表示从i到j,最大括号匹配数
如果第i个括号无法在[i+1, j]中匹配,那么dp[i][j] = dp[i+1][j];
否则如果在区间[i,j]中找到一个k,使得i和k配对,那么区间就被划分为2段,[i+1, k - 1]和[k+1,j]
所以dp[i][j] = max(dp[i +1][j], dp[i + 1][k - 1] + dp[k +1][j] + 2)
#include <map>
#include <set>
#include <list>
#include <stack>
#include <queue>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
char str[110];
int dp[110][110];
int main()
{
while (~scanf("%s", str), str[0] != 'e')
{
int len = strlen(str);
memset (dp, 0, sizeof(dp));
for (int i = len - 1; i >= 0; --i)
{
for (int j = i + 1; j < len; ++j)
{
dp[i][j] = dp[i + 1][j];
for (int k = i + 1; k <= j; ++k)
{
if ((str[i] == '(' && str[k] == ')') || (str[i] == '[' && str[k] == ']'))
{
dp[i][j] = max(dp[i][j], dp[i + 1][k - 1] + dp[k + 1][j] + 2);
}
}
}
}
printf("%d\n", dp[0][len - 1]);
}
return 0;
}