Period
Time Limit: 3000MS Memory Limit: 30000K
Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 1e6+1;
int Next[N];
int n;
char p[N];
void getnext(int length) {//next[i]表示i长度的匹配串所拥有的 最长相同前缀后缀 长度
Next[0] = -1;
int i = 0, j = -1;//i为pattern串的指针,j为Next数组的指针
while (i < length) {//没有到pattern的末尾
if (j == -1 || p[i] == p[j]) {//当前位置匹配
i++; //移动到下一个位置
j++;//匹配个数增加
Next[i] = j;//i位置的匹配数为j
}
else j = Next[j];//不匹配就向前回溯
}
}
int main() {
int count = 1;
while (scanf("%d",&n)&&n)
{
scanf("%s", p);
getnext(n);
printf("Test case #%d\n", count++);
for (int i = 1; i <= n; i++) {
if (i % (i - Next[i]) == 0 && i != (i - Next[i])) {
printf("%d %d\n", i, i / (i - Next[i]));
}
}
printf("\n");
}
return 0;
}