HDU 1019 Least Common Multiple GCD

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
 

 

 

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

 

 

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

 

 

Sample Input

 

2 3 5 7 15 6 4 10296 936 1287 792 1

 

 

Sample Output

 

105 10296

 

n组样例,每组m个数,求m个数的最小公倍数。
遍历一边,两两求即可。注意long long int  题目虽说答案是32位整数,但是(l*a)可能会爆int。

#include<iostream>
#include<string>
#include<algorithm>
#include<stack>
#include<map>
#include<vector>
#include<set>
#include<queue>
using namespace std;
const int maxn = 1e4;
int gcd(int a, int b)
{
	return a%b ? gcd(b, a%b) : b;
}
int main()
{
	//freopen("C://input.txt","r", stdin);
	int n;
	cin >> n;
	while (n--)
	{
		int m;
		cin >> m;
		long long int a,l;
		cin >> a;
		l = a;
		for (int i = 0; i < m-1; i++)
		{
			cin >> a;
			l = (l*a) / gcd(l, a);
		}
		printf("%lld\n", l);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值