LightOJ - 1010

Given an m x n chessboard where you want to place chess knights. You have to find the number of maximum knights that can be placed in the chessboard such that no two knights attack each other.
Those who are not familiar with chess knights, note that a chess knight can attack 8 positions in the board as shown in the picture below.

在这里插入图片

Input

Input starts with an integer T (≤ 41000), denoting the number of test cases.
Each case contains two integers m, n (1 ≤ m, n ≤ 200). Here m and n corresponds to the number of rows and the number of columns of the board respectively.

Output

For each case, print the case number and maximum number of knights that can be placed in the board considering the above restrictions.

Sample Input

3
8 8
3 7
4 10

Sample Output

Case 1: 32
Case 2: 11
Case 3: 20

题意

根据中国象棋“马”的棋子的跳棋规则,在给出的一个已知的棋盘大小中求出最大可以共存的“马”的数量。

思路

根据上图所示,可以发现“马”如果放在深色格子中,那么必会吃掉浅色格子中的“马”,所以,所有的“马”要有最大的共存量,那么所有的“马”都应该放在深色格子中或者浅色格子中。

AC代码

#include<stdio.h>

int main()
{
	int t;
	scanf("%d",&t);
	int c = 1;
	while(c <= t)
	{
		int m, n, p;
		int sum = 0;
		scanf("%d%d",&m, &n);
		if(m > n)//让 m 必须比 n 小
		{
			p = m;
			m = n;
			n = p;
		}
		if(m % 2 == 0 && m != 2)//m 为偶数的时候(m = 2 的时候是不一样的情况)
		{
			sum += m / 2 * n;
		}
		else if(m > 2)//m为基数的时候
		{
			sum += m / 2 * n + ((n + 1) / 2);
		}
		else if(m == 1)
		{
			sum += n;
		}
		else if(m == 2)
		{
			int q = n % 4;
			if(q == 0)
			{
				sum += n;
			}
			if(q == 1)
			{
				sum += n / 4 * 4 + 2;
			}
			if(q == 2 || q == 3)
			{
				sum += n / 4 * 4 + 4;
			}
		}
		printf("Case %d: %d\n",c, sum);
		c++;
	}
}

//这题的主要是找规律,找到规律后就是一道水题。但值得注意到是里面有一个坑,即m = 2 的时候,他就不能遵循一般规律了,得单独拿出来讨论。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值