POJ 2253 Frogger

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414
题意:有n个石头,以及n个石头的坐标,青蛙1在第一块石头上,
青蛙2在第二块石头上,问青蛙1到第二块石头上, 求图中经过权值
最大值,求最小的权值(即选择的路径中,权值的最大值,都比其他
路径中权值的最大值小)。 


转化一下,就是裸地最短路了。
注意点:
1.双向路径
2.POJ的输出,用%.lf会出错
Floyd写法
  
  
Accepted
Time32ms
Memory688kB
Length816
LangG++
Submitted
Shared
RemoteRunId18042202
#include <math.h>
#include <stdio.h>
#include <string.h>
#define max(x,y) ((x)>(y)?(x):(y))
struct node{
	int x, y;
}s[205];
double e[205][205];
double Sqrt(node a, node b) {
	return sqrt((a.x-b.x)*(a.x-b.x)+ (a.y-b.y)*(a.y-b.y));
}
int main() {
	int n;
	int Case = 1;
	while(~scanf("%d",&n) && n) {
		for(int i = 1; i <= n; i++) {
			scanf("%d %d",&s[i].x, &s[i].y);
		}
		for(int i = 1; i < n; i++) {
			for(int j = i+1; j <= n; j++) {
				e[i][j] = e[j][i] = Sqrt(s[i],s[j]);
			}
		}
		//Floyd
		for(int k = 1; k <= n; k++) {
			for(int j = 1; j < n; j++) {
				for(int i = j+1; i <= n; i++) {
					if(e[j][i] > max(e[j][k] , e[k][i])) {//双向路径
						e[j][i] = e[i][j] = max(e[j][k], e[k][i]);
					}
				}
			}
		}
		printf("Scenario #%d\n",Case++);
		printf("Frog Distance = %.3f\n\n",e[1][2]);
	}
	return 0;
}
//Dijkstra
  
  
StatusAccepted
Time16ms
Memory692kB
Length1077
LangG++
Submitted
Shared
RemoteRunId18041168
#include <math.h>
#include <stdio.h>
#include <string.h>
#define inf 0x3f3f3f3f
#define max(x,y) ((x)>(y)?(x):(y))
#define min(x,y) ((x)<(y)?(x):(y))
struct node{
	int x, y;
}s[205];
int book[205];
double dis[205];
double e[205][205];
double Sqrt(node a, node b) {
	return sqrt((a.x-b.x)*(a.x-b.x)+ (a.y-b.y)*(a.y-b.y));
}
int main() {
	int n;
	int Case = 1;
	while(~scanf("%d",&n) && n) {
		for(int i = 1; i <= n; i++) {
			scanf("%d %d",&s[i].x, &s[i].y);
		}
		for(int i = 1; i < n; i++) {
			for(int j = i+1; j <= n; j++) {
				e[i][j] = e[j][i] = Sqrt(s[i],s[j]);
			}
		} 
		for(int i = 1; i <= n; i++) {
			dis[i] = e[1][i];
		}
		for(int i = 1; i <= n; i++) {
			book[i] = 0;
		}
		book[1] = 1;
		int p;
		double mn;
		//Dijkstra 
		for(int i = 1; i < n; i++) {
			mn = inf;
			for(int j = 1; j <= n; j++) {
				if(book[j] == 0 && dis[j] < mn) {
					mn = dis[j];
					p = j;
				}
			}
			book[p] = 1;
			for(int k = 1; k <= n; k++) {
				dis[k] = min(dis[k], max(mn, e[p][k]));//松弛
			}
		}
		printf("Scenario #%d\n",Case++);
		printf("Frog Distance = %.3f\n\n",dis[2]);
	}
	return 0;
}
Bellman-Ford
#include <math.h>
#include <stdio.h>
#include <string.h>
#define inf 0x3f3f3f3f
#define max(x,y) ((x)>(y)?(x):(y))
#define min(x,y) ((x)<(y)?(x):(y))
struct node{
	double x, y;
	int u, v;
	double w;
}s[40005];
double dis[205];
double Sqrt(node a, node b) {
	return sqrt((a.x-b.x)*(a.x-b.x)+ (a.y-b.y)*(a.y-b.y));
}
int main() {
	int n;
	int Case = 1;
	while(~scanf("%d",&n) && n) {
		memset(s, 0, sizeof(s));
		for(int i = 1; i <= n; i++) dis[i] = inf;	
		for(int i = 1; i <= n; i++) {
			scanf("%lf %lf",&s[i].x, &s[i].y);
		}
		int t = 0;
		for(int i = 1; i <= n; i++) {
			for(int j = 1; j < i; j++) {
				s[t].u = i;
				s[t].v = j;
				s[t].w = Sqrt(s[i],s[j]);
				t++;	
			}
		}
		dis[1] = 0;
		for(int k = 1; k <= n; k++) {
			for(int i = 0; i < t; i++) {
				if(dis[s[i].v] > max(dis[s[i].u], s[i].w))//因为是双向路径 
				dis[s[i].v] = max(dis[s[i].u], s[i].w);
				if(dis[s[i].u] > max(dis[s[i].v], s[i].w))
				dis[s[i].u] = max(dis[s[i].v], s[i].w);
			}
		}
		printf("Scenario #%d\n",Case++);
		printf("Frog Distance = %.3f\n\n",dis[2]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值