Goldbach's conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:
Every even integer, greater than 2, can be expressed as the sum of two primes [1].
Now your task is to check whether this conjecture holds for integers up to 107.
Input
Input starts with an integer T (≤ 300), denoting the number of test cases.
Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).
Output
For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where
1) Both a and b are prime
2) a + b = n
3) a ≤ b
Sample Input
2
6
4
Sample Output
Case 1: 1
Case 2: 1
Hint
Every even integer, greater than 2, can be expressed as the sum of two primes [1].
Now your task is to check whether this conjecture holds for integers up to 107.
Input
Input starts with an integer T (≤ 300), denoting the number of test cases.
Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).
Output
For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where
1) Both a and b are prime
2) a + b = n
3) a ≤ b
Sample Input
2
6
4
Sample Output
Case 1: 1
Case 2: 1
Hint
1. An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, ...
题意:
一个偶数=两个素数相加,给定偶数N,求满足要求的素数对
注:数组开1e7会MT,提前计算素数个数,1e7以内只有六万多,轻松过
#include<cstdio>
#include<cstring>
using namespace std;
const int N=10000005;
int tot=0,ans[666666];//数组开小一点
bool v[N];//bool必须开N
void prime()
{
memset(v,true,sizeof(v));v[1]=false;
for(int i=2;i<N;++i)
{
if(v[i]) ans[tot++]=i;
for(int j=0;(j<tot)&&(i*ans[j]<N);++j)
{
v[i*ans[j]]=false;
if(i%ans[j]==0) break;
}
}
}
int main()
{
int t,n;
scanf("%d",&t);
prime();
for(int c=1;c<=t;++c)
{
int cnt=0;
scanf("%d",&n);
for( int i=0;ans[i]<=n/2;++i)
if(v[n-ans[i]]) cnt++;
printf("Case %d: %d\n",c,cnt);
}
return 0;
}