Squares
Description
A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.
So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.
So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.
Input
The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.
Output
For each test case, print on a line the number of squares one can form from the given stars.
Sample Input
4 1 0 0 1 1 1 0 0 9 0 0 1 0 2 0 0 2 1 2 2 2 0 1 1 1 2 1 4 -2 5 3 7 0 0 5 2 0
Sample Output
1 6 1
题意就是找出能组成正方形的点的个数。
学习了下STL中的binary_search
#include <algorithm> bool binary_search( forward_iterator start, forward_iterator end, const TYPE& val ); bool binary_search( forward_iterator start, forward_iterator end, const TYPE& val, Comp f );
如果找到了val, binary_search()返回true, 否则返回false. 如果函数f被指定, 它将代替比较元素值的函数operator < .
#include<cstdio>
#include<algorithm>
using namespace std;
struct point
{
int x,y;
}node[1005];
bool cmp(const struct point &a,const struct point &b)
{
return a.x==b.x?(a.y<b.y):(a.x<b.x);
}
int main()
{
int n;
struct point temp;
for(;(~scanf("%d",&n))&&n;)
{
int summ=0;
for(int i=0;i<n;++i)
scanf("%d%d",&node[i].x,&node[i].y);
sort(node,node+n,cmp);
for(int i=0;i<n;++i)
{
for(int j=i+1;j<n;++j)
{
temp.x=node[i].x+node[i].y-node[j].y;
temp.y=node[i].y-node[i].x+node[j].x;
if(!binary_search(node,node+n,temp,cmp))
continue;
temp.x=node[j].x+node[i].y-node[j].y;
temp.y=node[j].y-node[i].x+node[j].x;
if(!binary_search(node,node+n,temp,cmp))
continue;
summ++;
}
}
printf("%d\n",summ/2);
}
return 0;
}