Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。
Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。
当N为0时输入结束。
当N为0时输入结束。
Output
每个测试用例的输出占一行,输出全省畅通需要的最低成本。
Sample Input
3 1 2 1 0 1 3 2 0 2 3 4 0 3 1 2 1 0 1 3 2 0 2 3 4 1 3 1 2 1 0 1 3 2 1 2 3 4 1 0
Sample Output
3 1 0
# include<stdio.h>
# include<stdlib.h>
struct node{
int x,y,cost;
};
struct node road[6000];
int set[102];
int cmp(void const *a,void const *b)
{
struct node *c,*d;
c=(struct node *)a;
d=(struct node *)b;
return c->cost-d->cost;
}
int find(int x)
{
if(set[x]!=x)
set[x]=find(set[x]);
return set[x];
}
int main()
{
int i,n,t,x,y,sum,state;
while(scanf("%d",&n),n!=0)
{
t=n*(n-1)/2;
for(i=1;i<=n;i++)
set[i]=i;
for(i=0;i<t;i++)
{
scanf("%d%d%d%d",&road[i].x,&road[i].y,&x,&state);
if(state)
road[i].cost=0;
else
road[i].cost=x;
}
qsort(road,t,sizeof(road[0]),cmp);
sum=0;
for(i=0;i<t;i++)
{
x=find(road[i].x);
y=find(road[i].y);
if(x==y)
continue;
else
{
sum+=road[i].cost;
if(x<y)
set[y]=x;
else
set[x]=y;
}
}
printf("%d\n",sum);
}
return 0;
}