打开题目链接
Number Sequence
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 9688 Accepted Submission(s): 4433
Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
Sample Output
6 -1
题解:直接KMP算法。
AC code:
#include <iostream>
#include <string>
using namespace std;
int next[ 10005];
void nextfun(int str1[]){
int i=1,j=0;
next[1]=0;
while(i<=str1[0]){
if(j==0 || str1[i]==str1[j])
{
i++;j++;
next[i]=j;
}
else
j = next[j];
}
}
int KMP(int str[],int str1[]){
int i=1,j=1;
while(i<=str[0] && j<=str1[0]){
if(j==0 || str[i]==str1[j]){
i++;
j++;
}
else
j = next[j];
}
if(j>str1[0])
return i-j+1;
return -1;
}
int main()
{
// int str[ 1000005],str1[ 10005];
int t,n,m,i,j;
cin>>t;
while(t--){
memset(next,0,sizeof(next));
cin>>n>>m;
int *str = new int[1000005];
int *str1 = new int[10005];
for( j=0;j<n;j++)
cin>>str[j];
for(j =0; j<m;j++)
cin>>str1[j];
for(i = n-1; i>=0;i--)
str[i+1]=str[i];
str[0]=n;
for( i = m-1; i>=0;i--)
str1[i+1]=str1[i];
str1[0]=m;
nextfun(str1);
int k = KMP(str,str1);
cout<<k<<endl;
delete [] str;
delete [] str1;
}
return 0;
}