KMP HDU1358

                                                Period

                                    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                    Total Submission(s): 2525    Accepted Submission(s): 1246


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
  
  
3 aaa 12 aabaabaabaab 0
 

Sample Output
  
  
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
KMP算法。
  这道题考察的是KMP算法中next数组的应用,必须理解透next[]数组代表的含义才能通过它解决这道题。
  思路是先构造出 next[] 数组,下标为 i,定义一个变量 j = i - next[i] 就是next数组下标和下标对应值的差,如果这个差能整除下标 i,即 i%j==0 ,则说明下标i之前的字符串(周期性字符串长度为 i)一定可以由一个前缀周期性的表示出来,这个前缀的长度为刚才求得的那个差,即 j,则这个前缀出现的次数为 i/j 。所以最后输出i和i/j即可。
 
  举这道题的第二组输入样例为
  其next[]数组为:
  i      0  1  2  3  4  5  6  7  8  9  10 11
 a[i]    a  a  b  a  a  b  a  a  b  a  a  b
next[i] -1  0  1  0  1  2  3  4  5  6  7  8   

                        

  next[i]值是0或-1的忽略。

  注意:由于输出次数太多 (2 <= N <= 1 000 000),建议用printf输出,否则会超时。

AC code:

#include <iostream>
#include <string>
using namespace std;
int next[1000005];  
void getnext(char str[]){
  
	int i=0,j=-1;
	memset(next,0,sizeof(next));
	next[0]=-1;
	while(str[i]){
		if(j==-1 || str[i]==str[j])
		{
			i++;j++;
	    	next[i]=j;
		}
		else
			j = next[j];
	}
}
void kmp(char str[]){

	int i,t;
	for(i=2;str[i-1];i++){
		t= i-next[i];
		if(i%t==0 && i/t>1)
			cout<<i<<" "<<i/t<<endl;

	}

}
int main(){
 
	 char str[1000005];
	 int n,t=1;
	 while(cin>>n){
	 if(n==0)break;
	    cin>>str;
		printf("Test case #%d\n",t++);  
	      getnext(str);  
		      kmp(str);  
	     cout<<endl; 
	 }
 
	return 0;
}


 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值