Tri Tiling
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 1755 Accepted Submission(s): 996
Problem Description
In how many ways can you tile a 3xn rectangle with 2x1 dominoes? Here is a sample tiling of a 3x12 rectangle.

Input
Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 ≤ n ≤ 30.
Output
For each test case, output one integer number giving the number of possible tilings.
Sample Input
2 8 12 -1
Sample Output
3 153 2131
这个题目看了别人的递归公式:
a[i] = a[i-1] * 4 - a[i-2]; a[0]=1;a[2]=3; n为奇数时,为0;
AC code:
#include <iostream>
using namespace std;
int main()
{
__int64 a[35],n,i;
memset(a,0,sizeof(a));
a[0]=1;a[2]=3;
for(i=4; i<=30; i+=2)
a[i]=4*a[i-2]-a[i-4];
while(~scanf("%I64d",&n))
{
if(n==-1)
break;
printf("%I64d\n",a[n]);
}
return 0;
}