HDU:1513 Palindrome(回文字符串+最长公共子序列+滚动数组)

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5246    Accepted Submission(s): 1800


Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.  

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
 

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 

Sample Input
  
  
5 Ab3bd
 

Sample Output
  
  
2
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   1505  1506  1074  1003  1510 
 
 
题目大意:给你一个字符串,问至少需要修改几个字母才能使得该字符串是回文字符串呢?
解题思路:需要加的字符的个数=原来字符串的长度-(原来字符串和逆字符串的最长公共子序列的长度),于是相当于求LCS;但是这道题字符串长度最多为5000,对内存有限制要求,那么我们这里用滚动数组来写。
代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[2][5010];//第一维要么为奇数要么为偶数 
char s1[5010];
char s2[5010];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		scanf("%s",s1);
		for(int i=0;i<n;i++)//构造s1的反转字符串 
		{
			s2[i]=s1[n-i-1];
		}
		s2[n]='\0';//别忘了这个 
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				if(s1[i-1]==s2[j-1])
				{
					dp[i%2][j]=dp[(i-1)%2][j-1]+1;
				}
				else
				{
					dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);
				}
			}
		}
		printf("%d\n",n-dp[n%2][n]);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值