Problem Description
已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历和层序遍历。
Input
输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。
Output
每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列。
Example Input
2 abdegcf dbgeafc xnliu lnixu
Example Output
dgebfca abcdefg linux xnuli
Hint
Author
ma6174
#include<stdio.h>
#include<iostream>#include<malloc.h>
#include<queue>
#include<string.h>
using namespace std;
typedef struct node
{
char data;
struct node *l,*r;
} st;
char s1[55],s2[55];
void creat(st *&root,int xxl,int xxr,int zxl,int zxr)
{
if(xxl>xxr)
root= NULL;
else
{
int k;
root=new node;
root->data=s1[xxl];
for(int j=zxl; j<=zxr; j++)
{
if(s2[j]==s1[xxl])
{
k=j;
break;
}
}
int numleft=k;
creat(root->l,xxl+1,xxl+numleft-zxl,zxl,numleft-1);
creat(root->r,xxl+numleft+1-zxl,xxr,numleft+1,zxr);
}
}
void hx(st *root)
{
if(root==NULL)
return ;
else
{
hx(root->l);
hx(root->r);
printf("%c",root->data);
}
}
void cx(st *root)
{
if(root==NULL)
return;
else
{
queue<st*>w;
w.push(root);
while(!w.empty())
{
st *q;
printf("%c",w.front()->data);
q=w.front();
w.pop();
if(q->l)
w.push(q->l);
if(q->r) w.push(q->r);
}
}
}
int main()
{
int n,len,i;
cin>>n;
while(n--)
{
st *root;
i=0;
scanf("%s",s1);
scanf("%s",s2);
len=strlen(s1);
creat(root,0,len-1,0,len-1);
hx(root);
cout<<endl;
cx(root);
cout<<endl;
}
}