数据结构实验之求二叉树后序遍历和层次遍历

本文介绍了一种根据给定的二叉树前序和中序遍历序列,计算并输出该二叉树的后序遍历和层序遍历序列的算法。通过递归方式构造二叉树,并实现了后序遍历和层序遍历的输出。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem Description

 已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历和层序遍历。

Input

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。

Output

每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列。

Example Input
2
abdegcf
dbgeafc
xnliu
lnixu
Example Output
dgebfca
abcdefg
linux
xnuli
Hint
Author
ma6174




#include<stdio.h>

#include<iostream>
#include<malloc.h>
#include<queue>
#include<string.h>
using namespace std;


typedef struct node
{
    char data;
    struct node *l,*r;
} st;
char s1[55],s2[55];


void creat(st *&root,int xxl,int xxr,int zxl,int zxr)
{
    if(xxl>xxr)
        root= NULL;
    else
    {
        int k;
        root=new node;
        root->data=s1[xxl];
        for(int j=zxl; j<=zxr; j++)
        {
            if(s2[j]==s1[xxl])
            {
                k=j;
                break;
            }


        }
        int numleft=k;
        creat(root->l,xxl+1,xxl+numleft-zxl,zxl,numleft-1);
        creat(root->r,xxl+numleft+1-zxl,xxr,numleft+1,zxr);
    }
}
void hx(st *root)
{
    if(root==NULL)
        return ;
    else
    {
        hx(root->l);
        hx(root->r);
        printf("%c",root->data);
    }
}
void cx(st *root)
{
    if(root==NULL)
        return;
    else
    {
        queue<st*>w;
        w.push(root);
        while(!w.empty())
        {
            st *q;
            printf("%c",w.front()->data);


            q=w.front();


            w.pop();
            if(q->l)
                w.push(q->l);
            if(q->r) w.push(q->r);
        }
    }
}
int main()
{
    int n,len,i;
    cin>>n;
    while(n--)
    {
        st *root;
        i=0;
        scanf("%s",s1);
        scanf("%s",s2);
        len=strlen(s1);
        creat(root,0,len-1,0,len-1);
        hx(root);
        cout<<endl;
        cx(root);
        cout<<endl;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值