数据结构实验之二叉树五:层序遍历
Time Limit: 1000MS
Memory Limit: 65536KB
Problem Description
已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。
Input
输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是
一个长度小于50个字符的字符串。
Output
输出二叉树的层次遍历序列。
Example Input
2 abd,,eg,,,cf,,, xnl,,i,,u,,
Example Output
abcdefg xnuli
Hint
Author
xam
#include<stdio.h>
#include<iostream>#include<malloc.h>
#include<queue>
using namespace std;
typedef struct node
{
int data;
struct node *l,*r;
} st;
char s[1010];
int i;
st *creat()
{
st *root;
char c;
c=s[i++];
if(c==',')
return NULL;
else
{
root=(st *)malloc(sizeof(st));
root->data=c;
root->l=creat();
root->r=creat();
}
return root;
}
void cx(st *root)
{
if(root==NULL)
return;
else
{
queue<st*>w;
w.push(root);
while(!w.empty())
{
st *q;
printf("%c",w.front()->data);
q=w.front();
w.pop();
if(q->l)
w.push(q->l);
if(q->r)
w.push(q->r);
}
}
}
int main()
{
int n;
cin>>n;
while(n--)
{
scanf("%s",s);
st *root;
root=(st *)malloc(sizeof(st));
i=0;
root=creat();
cx(root);
cout<<endl;
}
}