hdoj 1397 Goldbach's Conjecture (大数素数打表)

博客讲述了在解决hdoj 1397问题时,由于合数分解导致的TLE错误,从而采用素数打表的方法应对大数范围(2^15)内的素数判断。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >


这道题本以为就是简单的合数分解,求素数组合数,没想到总是TLE,后来才发现里面的数范围特别大 2^15,所以只能打表了(把所有2^15以内素数标记为1,不是的标记为0)



Goldbach's Conjecture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5320    Accepted Submission(s): 2043


Problem Description
Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2. 
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.
 

Input
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.
 

Output
Each output line should contain an integer number. No other characters should appear in the output.
 

Sample Input
  
  
6 10 12 0
 

Sample Output
  
  
1 2 1
 
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<iostream>
using namespace std;
#define max (1<<15)+10
bool prime[max];
void fun()
{
	memset(prime,1,sizeof(prime));
	for(int i=2;i<max;i++)
		for(int j=2;j<=sqrt(i);j++)
		{
			if(i%j==0)
			{
				prime[i]=0;
				break;	
			}
		}
		prime[0]=prime[1]=0;
}
/*void calcPrime()

{
    memset(prime, true, sizeof(prime));   //另一种达标方法,我试了下,比自己的还慢 
    for(int i=2; i<max; i++)
    {
       for(int j=i*2; j<max; j+=i) 
	   prime[j] = false;
    }
    prime[0] = prime[1] = false;
}*/

int main()
{	
	fun(); //必须调用先把素数标记出来,后边才能判断 
	int m,n;
	while(scanf("%d",&n)&&n)
	{    m=0;
		/*for(int i=2;i<=n/2 ;i++)
		{
			if(prime[i] && prime[n-i])
			{
			  m++;	
			}  
		}*/
		 
		 for(int i=2; i<=n/2; i++)

            if(prime[i] && prime[n-i]) m++;
            
		printf("%d\n",m);
	}
	return 0;
}


标题Python网络课程在线学习平台研究AI更换标题第1章引言介绍Python网络课程在线学习平台的研究背景、意义、国内外现状和研究方法。1.1研究背景与意义阐述Python在线学习平台的重要性和研究意义。1.2国内外研究现状概述国内外Python在线学习平台的发展现状。1.3研究方法与论文结构介绍本文的研究方法和整体论文结构。第2章相关理论总结在线学习平台及Python教育的相关理论。2.1在线学习平台概述介绍在线学习平台的基本概念、特点和发展趋势。2.2Python教育理论阐述Python语言教学的理论和方法。2.3技术支持理论讨论构建在线学习平台所需的技术支持理论。第3章Python网络课程在线学习平台设计详细介绍Python网络课程在线学习平台的设计方案。3.1平台功能设计阐述平台的核心功能,如课程管理、用户管理、学习跟踪等。3.2平台架构设计给出平台的整体架构,包括前后端设计、数据库设计等。3.3平台界面设计介绍平台的用户界面设计,强调用户体验和易用性。第4章平台实现与测试详细阐述Python网络课程在线学习平台的实现过程和测试方法。4.1平台实现介绍平台的开发环境、技术栈和实现细节。4.2平台测试对平台进行功能测试、性能测试和安全测试,确保平台稳定可靠。第5章平台应用与效果分析分析Python网络课程在线学习平台在实际应用中的效果。5.1平台应用案例介绍平台在实际教学或培训中的应用案例。5.2效果评估与分析通过数据分析和用户反馈,评估平台的应用效果。第6章结论与展望总结Python网络课程在线学习平台的研究成果,并展望未来发展方向。6.1研究结论概括本文关于Python在线学习平台的研究结论。6.2研究展望提出未来Python在线学习平台的研究方向和发展建议。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值